Opened 8 years ago

Closed 8 years ago

#10066 closed Bug Report - General (Unverified)

Mythnews hardlock

Reported by: warpme@… Owned by: beirdo
Priority: minor Milestone: unknown
Component: Plugin - MythNews Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi, Despite I can't verify it for 100% (as there is always probability that observation window was too short), attached patch seems to solve hard locks for me (but with price of 1 sec additional delay per bookmark). Without patch system hard locks (dead kbd, screen; only hard reset helps) approx. every few mythnews launches (it also hard locks on mythnevision, albeit I'm using my thnetvision sparadically). With attached patch I tested mythnews for 200 feeds refreshes without hard lock. I'm on v0.25pre-3370-g7fa4d4e-dirty-20110924.

Attachments (1)

mythtv-master-httpool_delay.patch (1.8 KB) - added by warpme@… 8 years ago.
Patch for delaying AddURLlistener

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by warpme@…

Patch for delaying AddURLlistener

comment:1 Changed 8 years ago by beirdo

Owner: set to beirdo
Status: newassigned

This is not a good fix. Delaying in random unrelated places in the code is not the fix to something hanging or blocking elsewhere.

We need to find the actual problem with proper debugging, and fix it.

comment:2 Changed 8 years ago by beirdo

Status: assignedinfoneeded

Could you please get us a backtrace while the program is hung? Instructions are on the wiki.

comment:3 Changed 8 years ago by warpme@…

Gavin, Thx for Your replay. Probably I wasn't clear enough in OP in this ticket. By attaching patch in this ticket I absolutely not aspire to provide solution. It is only workaround for my issue and attempt to demonstrate that issue might be app related - not OS or HW.

I was trying hard to catch meaningful traces/logs - but hang nature (hard hang with frozen screen/kbd/mice/network) causes that I was forced to switch problem resolution from analyzing logs/traces to playing what-if with code.

I disagree that my attempt of "Delaying in random unrelated places" is blind type of resolving issue as it has concrete hypothesis in mind + gives 2 positive aspects: 1\hides issue so I can use mythnews; 2\narrows code area where root cause might be. I was hoping it will helpful to solve issue by code audit by person well understanding code design - but I see I was wrong. No problem for me. After all - I can live with 500msec delay for every news feed. Currently I haven't idea how to get trace from hard locked diskless system where screen/kbd/mice/network are dead.

comment:4 Changed 8 years ago by beirdo

The only thing that I can think of that could be causing a hardlock from the application layer in Linux is something that crosses over into the kernel layer. In the areas you are looking at (mythnews, mythnetvision), the common factor seems to be mythbrowser. The one thing I can think of there that could be doing something in the kernel is Flash with its use of the 3d acceleration in the GPU.

SO... Could you list what GPU, what OpenGL version and supplier (glxinfo should give that), what version of Flash... and anything else along that line that might be useful. Also is this a 32bit or 64bit system?

comment:5 Changed 8 years ago by warpme@…

Gavin, I'm using Atom v1 platform with 64bit compiled minimyth derivate. GPU is nv9400M (IGP C79), OpenGL renderer: ION/PCI/SSE2, OpenGL version : 3.3.0 NVIDIA 280.13, flash is flashplayer11_rc1_install_lin_64_090611. During weekend I will try remove flash and launch long series of tests. Will report how it goes.

comment:6 Changed 8 years ago by warpme@…

Hi, FYI: removing flash plugin is not helping. Hard lock was on 3rd launch of myth news. br

comment:7 Changed 8 years ago by Raymond Wagner

Status: infoneededassigned

Backtrace reported not possible, remove infoneeded tag.

comment:8 Changed 8 years ago by beirdo

Status: assignedinfoneeded

I wonder if using Alt-SysRq?-L wouldn't be helpful. This should give a full stack trace of all running processes (i.e. on the CPU currently) on the console, and also to /var/log/kern.log (on my box anyways) as long as the syslog process is working. If you try this on a box that seems hung, see if you can't get us some output?

I (so far) can't reproduce any such hangs.

comment:9 Changed 8 years ago by warpme@…

Gavin, I will try catch hang and see is Alt-SysRq??-L working. Unfortunately I'm pessimist, as last time when I had hardlock (it was before applying patch from this ticket) I tried all methods listed in kernel documentation (I believe at that time I tried also CPU dumps triggered by kbd keystrokes) - no luck. HW behaves as totally hardlocked (no any reaction to KBD nor Eth). This was reason why I was forced to change approach to approach with selective code modifications. Strange as I can't find issue correlation with particular software combination nor many other users having this issue (so far I saw only 2 reports of such hardlock: me and #13 in http://www.gossamer-threads.com/lists/mythtv/users/485896?search_string=mythnews;#485896). Maybe this is related to my RSS feeds ?

comment:10 Changed 8 years ago by warpme@…

Hi, In past days I removed httppool_delay patch had 2 hardlocks. Unfortunately hard-locked system has completely dead kbd (even num lock is non-working) - so pressing Alt-SysRq?-L isn't helpful. Thing must be non-trivial as eth works for ping but telnet is non-functional (it says it is connected but didn't give prompt). My kbd is on USB (no nice hi_prio INT from 8042). Possible theory might be that hardlock is gfx INT handler and blocks whole userspace. If USB INT has lower priority than GFX INT - kbd will be also dead. Fortunately LAN is working. I will try netconsole and will keep You informed. Br.

comment:11 Changed 8 years ago by beirdo

Resolution: Unverified
Status: infoneededclosed

Closing this for lack of updates.

Note: See TracTickets for help on using tickets.