Opened 8 years ago

Closed 8 years ago

#10117 closed Bug Report - Crash (Works for me)

mythtv-setup borked by 87b89dee6c8c

Reported by: beirdo Owned by: cpinkham
Priority: major Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When starting mythtv-setup with an empty database (new install), it crashes right after the language/locale selection screen. I performed a git bisect, and this was the offending commit. I've since retested with this locally reverted, and the crash disappears.

If needed, I'll dredge up the backtraces, but it should be easily reproducable.

Change History (2)

comment:1 Changed 8 years ago by Robert Kulagowski

I've been seeing something similar; still tracking down if it's related.

If there are multiple backends running different versions of MythTV (.23 and trunk in my case), mythfrontend will correctly show that there are multiple servers via upnp discovery. However, if trunk mythfrontend connects to trunk mythtv backend, a grey popup appears (this is with Terra) but there is no text in the popup.

However, settings are not preserved.

If mythfrontend is started with -d (disable auto discovery) the user is prompted to fill in database parameters and settings are preserved.

I will add additional information once I'm in front of the box.

comment:2 Changed 8 years ago by cpinkham

Resolution: Works for me
Status: newclosed

This is working fine here, it was probably fixed by 098ead8 which fixed an issue with a pointer to the main screen stack being used after the stack was deleted.

Note: See TracTickets for help on using tickets.