Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10126 closed Developer Task (fixed)

udefined references to opengl while building libmythui

Reported by: screendisease@… Owned by: markk
Priority: minor Milestone: 0.25
Component: MythTV - configure script Version: Master Head
Severity: medium Keywords: GL_GLEXT_PROTOTYPES mythrender_opengl2es.h opengl
Cc: Ticket locked: no

Description (last modified by sphery)

Hi devteam,

in order to build libmythui , i have to add the following CXXFFLAGS

-DGL_GLEXT_PROTOTYPES

otherwise the build will fail with undefined references to

mythrender_opengl2es.h: In member function 'virtual void MythRenderOpenGL2ES::InitProcs()':
mythrender_opengl2es.h:27:57: error: 'glCreateShader' was not declared in this scope
mythrender_opengl2es.h:28:57: error: 'glShaderSource' was not declared in this scope
mythrender_opengl2es.h:29:58: error: 'glCompileShader' was not declared in this scope
mythrender_opengl2es.h:30:57: error: 'glAttachShader' was not declared in this scope
mythrender_opengl2es.h:31:56: error: 'glGetShaderiv' was not declared in this scope
mythrender_opengl2es.h:32:61: error: 'glGetShaderInfoLog' was not declared in this scope
mythrender_opengl2es.h:33:57: error: 'glDetachShader' was not declared in this scope
mythrender_opengl2es.h:34:57: error: 'glDeleteShader' was not declared in this scope
mythrender_opengl2es.h:36:59: error: 'glDeleteProgram' was not declared in this scope
mythrender_opengl2es.h:37:59: error: 'glCreateProgram' was not declared in this scope
mythrender_opengl2es.h:38:57: error: 'glLinkProgram' was not declared in this scope
mythrender_opengl2es.h:39:56: error: 'glUseProgram' was not declared in this scope
mythrender_opengl2es.h:40:63: error: 'glGetProgramInfoLog' was not declared in this scope
mythrender_opengl2es.h:41:58: error: 'glGetProgramiv' was not declared in this scope
mythrender_opengl2es.h:43:66: error: 'glGetUniformLocation' was not declared in this scope
mythrender_opengl2es.h:44:57: error: 'glUniform4f' was not declared in this scope
mythrender_opengl2es.h:45:64: error: 'glUniformMatrix4fv' was not declared in this scope
mythrender_opengl2es.h:46:67: error: 'glVertexAttribPointer' was not declared in this scope
mythrender_opengl2es.h:48:76: error: 'glEnableVertexAttribArray' was not declared in this scope
mythrender_opengl2es.h:49:77: error: 'glDisableVertexAttribArray' was not declared in this scope
mythrender_opengl2es.h:50:71: error: 'glBindAttribLocation' was not declared in this scope
mythrender_opengl2es.h:51:67: error: 'glVertexAttrib4f' was not declared in this scope
mythrender_opengl2es.h:53:52: error: 'glGenBuffers' was not declared in this scope

have a nice day:-)

Change History (4)

comment:1 Changed 8 years ago by sphery

Component: Contributed Scripts & AppsMythTV - configure script
Description: modified (diff)
Owner: changed from sphery to markk
Status: newassigned

Mark, I'm sending this your way since you're the man with the plan for OpenGL ES.

Not sure if this is something that needs fixing in configure or in the .pro files, but "MythTV - configure script" is a better fit than "Contributed Scripts & Apps".

comment:2 Changed 8 years ago by Github

OpenGL: Move some defines from libmythtv to libmythui.

Refs #10126

Branch: master Changeset: 32b21f3dd24a8f849e2aa6d0063336c52c47914b

comment:3 Changed 8 years ago by markk

Milestone: 0.24.20.25
Resolution: Fixed
Status: assignedclosed

This should be fixed in master but I was not able to reproduce. If it is still a problem, please reopen.

comment:4 Changed 8 years ago by Github

Resolution: Fixedfixed

OpenGL ES: Use internal API entrypoints throughout.

Should fix #10126

Branch: master Changeset: c87a5a7aaa23955e0e33b05b4ea6379df64228ab

Note: See TracTickets for help on using tickets.