Opened 14 years ago

Closed 14 years ago

#1014 closed defect (fixed)

A new record rule can interfere with a live session.

Reported by: bjm Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The scheduler is unaware of a tuner in use for live TV and will change the state of the recorder if a new recording is assigned to the same card as a current live session.

To reproduce,

  • Enter live TV while there are no recordings in progress.
  • Press "Y" if necrssary to change to the card of the first input fror the primary source.
  • Press "R" to record.
  • Start or go to another mythfrontend or mythweb session.
  • Go to the EPG and single record any other show in progress from the primary source.

At this point, the card/input have not been reserved yet by the scheduler. The scheduler starts the new recording on the first available input which is the card in use for the live session(!). The live playback session changes channels to the station of the newly requested show. The file requested with TOGGLERECORD is stopped and a new file is started for the show requested from the EPG.

The point of this test was to demonstrate that TOGGLERECORD needs to inform the scheduler of the recording in progress as soon as the request is made. However, it turns out that scheduling a show in progress while there is a live session will change the channel on the live playback regardless of whether "R" was pressed or not.

Change History (1)

comment:1 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [8621]) Fixes #1014.

I'm looking at informing the scheduler about LiveTV recordings early so that recordings are overridden by the scheduler, but this change is needed to make sure the scheduler can't preempt LiveTV when an in progress recording is scheduled on another frontend.

Note: See TracTickets for help on using tickets.