Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#10160 closed Bug Report - Crash (Works for me)

mythgallery crash - viewing a 2nd album

Reported by: Karl Richter-Trummer <karlrt@…> Owned by: beirdo
Priority: major Milestone: unknown
Component: Plugin - MythGallery Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

reported the bug at https://bugs.launchpad.net/mythbuntu/+bug/882999 but thought its better to report it upstream too.

I use the latest mythbuntu 0.24 fixes.

When using mythgallery, i can view the fotos and albums, but only one album. When i attempt to open a 2nd album, whole mythfrontend.real crashes.

Howto reproduce: 1) view a photoalbum in mythgallery 2) go out of that album (esc) and view a 2nd album or even enter the same album 3) mythgallery crashes

Attachments (3)

ThreadStacktrace.txt (36.1 KB) - added by Marc Randolph <mrand@…> 7 years ago.
Stacktrace.txt (14.8 KB) - added by Marc Randolph <mrand@…> 7 years ago.
mythfrontend.log.txt.gz (65.4 KB) - added by Marc Randolph <mrand@…> 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by beirdo

Status: newinfoneeded_new

This needs:

  • mythfrontend --version output
  • full backtrace from a debug build.

Without this, there's not much chance it will get fixed.

comment:2 Changed 7 years ago by Marc Randolph <mrand@…>

Looks like the title of this should be:

mythfrontend crashed with SIGSEGV in QSpiAccessibleBridge:: although the last none QT related item appears to be: MythDialog::MythDialog?

which seems to be confirmed by what I see in the frontend log:

show SingleView?(0x7fff81d96640, name = "SingleView?") not the same: QObject(0x0) MythDialog?(0x7fff81d96640, name = "SingleView?") at path: "/org/a11y/atspi/accessible/140735371896384"

Attaching stack and thread traces, as well as log file with version output

Changed 7 years ago by Marc Randolph <mrand@…>

Attachment: ThreadStacktrace.txt added

Changed 7 years ago by Marc Randolph <mrand@…>

Attachment: Stacktrace.txt added

Changed 7 years ago by Marc Randolph <mrand@…>

Attachment: mythfrontend.log.txt.gz added

comment:3 Changed 7 years ago by beirdo

Resolution: Works for me
Status: infoneeded_newclosed

I can not reproduce this problem in master. As we are rapidly moving into a release cycle, I'm not planning on spending too much time trying to backtrack and fix 0.24-only bugs.

Can you reproduce in master? If so, please reopen.

comment:4 Changed 7 years ago by beirdo

This was also tested in recent 0.24-fixes, and was not reproducible there either

Note: See TracTickets for help on using tickets.