Opened 14 years ago

Closed 14 years ago

#1018 closed defect (fixed)

viewing program details behaves abnormally (svn 8575)

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: low Keywords:
Cc: Ticket locked: no

Description

Attempting to view program details (when viewing a specific program, going to schedule information->program details) behaves oddly.

Using themes from svn (tried Iulius and Titivilus), frontend segfaults with

QPainter::begin: Cannot paint null pixmap
QPainter::setPen: Will be reset by begin()
QPainter::setBrush: Will be reset by begin()
QPainter::setBrush: Will be reset by begin()
QPainter::setPen: Will be reset by begin()
QPainter::setWorldMatrix: Will be reset by begin()
QPainter::setClipRegion: Will be reset by begin()
QPainter::setClipping: Will be reset by begin()
QPainter::setWorldMatrix: Will be reset by begin()
QPainter::setWorldMatrix: Will be reset by begin()
QPainter::setPen: Will be reset by begin()
QPainter::setFont: Will be reset by begin()
QPainter::setPen: Will be reset by begin()

When using older themes (e.g. from 18.2, tested with Titivilus, Iulius and Retro), frontend displays a dialog box saying

Could not locate 'progdetails' in theme".

Returning to the previous menu.

and then displays a blank screen (with the theme bg) which can be exited from.

Also experienced with 8566.

Change History (4)

comment:1 Changed 14 years ago by anonymous

Can confirm the same behaviour here, although it occurs on only one of my machines. I've completely deleted and re-installed all myth files on the off-chance that it was just an old or broken theme file but it made no difference. I will attach a backtrace when I get the opportunity. The log displays the same QPainter issues as above. I'm using the MythCenter? theme.

comment:2 Changed 14 years ago by paulh

(In [8626]) UIRichTextType was assuming everyone uses a color depth of 24 bits when creating its pixmaps.

Hopefully fixes the problem some people have had with the program details screen.

Anonymous can you please close the ticket if it fixes the problem for you. References #1018

comment:3 Changed 14 years ago by anonymous

Fixes the issue for me but I'm not the original anon, so I'm reluctant to close the ticket myself. Probably safe for a dev to decide this bug is fixed.

comment:4 Changed 14 years ago by anonymous

Resolution: fixed
Status: newclosed

This is original anon. Updated to 8626, and my themes to svn, and I can confirm it works. The progdetails dialog error was due to me using old theme versions.

Note: See TracTickets for help on using tickets.