Opened 8 years ago

Closed 8 years ago

#10180 closed Bug Report - General (Duplicate)

cannot build mythtv with opengles enabled

Reported by: yiannividalis@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The problem occurs with current master,i.e. after #10126 was closed, and the error I get is:

make[2]: Entering directory `/root/mythtv-git/mythtv/libs/libmythui'
ccache g++ -c -pipe -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fomit-frame-pointer -pthread -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -O3 -fvisibility-inlines-hidden -Wmissing-declarations -fvisibility=hidden -D_REENTRANT -fPIC -DMMX -Di386 -D_GNU_SOURCE -DUSING_X11 -DUSING_XRANDR -DUSE_OPENGL_PAINTER -DUSING_OPENGLES -DUSING_QTWEBKIT -DMUI_API -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/default -I. -I/usr/include/QtCore -I/usr/include/QtNetwork -I/usr/include/QtGui -I/usr/include/QtOpenGL -I/usr/include/QtXml -I/usr/include/QtSql -I/usr/include/QtWebKit -I/usr/include -I/usr/include -I/usr -I/usr/include/libxml2 -I../libmythbase -I../.. -I.. -I../../external/FFmpeg -I/usr/X11R6/include -I. -o mythrender_opengl.o mythrender_opengl.cpp
In file included from mythrender_opengl.cpp:12:0:
mythrender_opengl2es.h: In member function ‘virtual void MythRenderOpenGL2ES::InitProcs()’:
mythrender_opengl2es.h:27:53: error: ‘glCreateShader’ was not declared in this scope
mythrender_opengl2es.h:28:53: error: ‘glShaderSource’ was not declared in this scope
mythrender_opengl2es.h:29:55: error: ‘glCompileShader’ was not declared in this scope
mythrender_opengl2es.h:30:53: error: ‘glAttachShader’ was not declared in this scope
mythrender_opengl2es.h:31:51: error: ‘glGetShaderiv’ was not declared in this scope
mythrender_opengl2es.h:32:61: error: ‘glGetShaderInfoLog’ was not declared in this scope
mythrender_opengl2es.h:33:53: error: ‘glDetachShader’ was not declared in this scope
mythrender_opengl2es.h:34:53: error: ‘glDeleteShader’ was not declared in this scope
mythrender_opengl2es.h:36:55: error: ‘glDeleteProgram’ was not declared in this scope
mythrender_opengl2es.h:37:55: error: ‘glCreateProgram’ was not declared in this scope
mythrender_opengl2es.h:38:51: error: ‘glLinkProgram’ was not declared in this scope
mythrender_opengl2es.h:39:49: error: ‘glUseProgram’ was not declared in this scope
mythrender_opengl2es.h:40:63: error: ‘glGetProgramInfoLog’ was not declared in this scope
mythrender_opengl2es.h:41:53: error: ‘glGetProgramiv’ was not declared in this scope
mythrender_opengl2es.h:43:65: error: ‘glGetUniformLocation’ was not declared in this scope
mythrender_opengl2es.h:44:47: error: ‘glUniform4f’ was not declared in this scope
mythrender_opengl2es.h:45:61: error: ‘glUniformMatrix4fv’ was not declared in this scope
mythrender_opengl2es.h:46:67: error: ‘glVertexAttribPointer’ was not declared in this scope
mythrender_opengl2es.h:48:75: error: ‘glEnableVertexAttribArray’ was not declared in this scope
mythrender_opengl2es.h:49:77: error: ‘glDisableVertexAttribArray’ was not declared in this scope
mythrender_opengl2es.h:50:65: error: ‘glBindAttribLocation’ was not declared in this scope
mythrender_opengl2es.h:51:57: error: ‘glVertexAttrib4f’ was not declared in this scope
mythrender_opengl2es.h:53:49: error: ‘glGenBuffers’ was not declared in this scope
mythrender_opengl2es.h:54:49: error: ‘glBindBuffer’ was not declared in this scope
mythrender_opengl2es.h:55:55: error: ‘glDeleteBuffers’ was not declared in this scope
mythrender_opengl2es.h:56:49: error: ‘glBufferData’ was not declared in this scope
make[2]: *** [mythrender_opengl.o] Error 1
make[2]: Leaving directory `/root/mythtv-git/mythtv/libs/libmythui'
make[1]: *** [sub-libmythui-make_default] Error 2
make[1]: Leaving directory `/root/mythtv-git/mythtv/libs'
make: *** [libs] Error 2

It happens on my old centrino duo laptop that I just upgraded to OpenSuSE 12.1. It has Mesa-devel 7.11-11.1.2.

MythTV Version : v0.25pre-3796-g34b90ac-dirty
MythTV Branch : master
Network Protocol : 69
Library API : 0.25.20111116-1
QT Version : 4.7.4
Options compiled in:
 linux release use_hidesyms using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_firewire using_frontend using_hdpvr using_iptv using_ivtv using_libfftw3 using_libxml2 using_libudf using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_ffmpeg_threads using_live using_mheg using_libxml2 using_libudf

Thanks,

Yianni.

Change History (2)

comment:1 Changed 8 years ago by yiannividalis@…

Apparently it was a duplicate of 10126, which was fixed by commit c87a5a7aaa23955e0e33b05b4ea6379df64228ab.

Please close this as fixed, too.

Thanks, Mark.

comment:2 Changed 8 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Duplicate
Status: newclosed

Duplicate of #10126.

Note: See TracTickets for help on using tickets.