Opened 7 years ago

Closed 20 months ago

#10197 closed Bug Report - General (Unverified)

Shutdown from Mythwelcome does not trigger wakeup

Reported by: martin.bantz@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Mythwelcome & Mythshutdown Version: Master Head
Severity: medium Keywords: mythwelcome wakeup shutdown
Cc: Ticket locked: no

Description

In a combined mythbackend and mythfrontend, mythwelcome does not trigger the set wakeup routine when selecting 'Shutdown now'

Change History (4)

comment:1 Changed 7 years ago by beirdo

Component: MythTV - GeneralMythTV - Mythwelcome & Mythshutdown

comment:2 Changed 5 years ago by Matthias Hofmann <borim7@…>

The configured "command to set wakeup time" (in my case: sudo /usr/sbin/rtcwake -m no -t $time) is not executed, when "mythshutdown --shutdown" is executed. Instead the default command "/usr/bin/nvram-wakeup --settime $time" is executed.

In the source code at mythtv/programs/mythshutdown/main.cpp:659 the command is fetched from the configuration and always the default command is returned. Another point is that the configuration is fetched in another way as in the rest of the file. Normally the static function getGlobalSetting is used, but for the wakeup time command "gCoreContext->GetSetting?(...)" is used. I do not know if this is the reason for the bug.

When this bug gets fixed, it would be nice if mythshutdown gets an option to set the wakeup time without shutting down.

I use:

  • Ubuntu 14.04 (x64)
  • Mythtv 0.27 (2:0.27.0+fixes.20140324.8ee257c-0ubuntu3)
  • Frontend and Backend on the same machine

comment:3 in reply to:  2 Changed 20 months ago by Jonatan Lindblad

Replying to Matthias Hofmann <borim7@…>:

The configured "command to set wakeup time" (in my case: sudo /usr/sbin/rtcwake -m no -t $time) is not executed, when "mythshutdown --shutdown" is executed. Instead the default command "/usr/bin/nvram-wakeup --settime $time" is executed.

In the source code at mythtv/programs/mythshutdown/main.cpp:659 the command is fetched from the configuration and always the default command is returned. Another point is that the configuration is fetched in another way as in the rest of the file. Normally the static function getGlobalSetting is used, but for the wakeup time command "gCoreContext->GetSetting?(...)" is used. I do not know if this is the reason for the bug.

This means you haven't configured mythwelcome/mythshutdown properly. There is one setting in mythtv-setup and another in mythwelcome. You have most likely only configured the one in mythtv-setup but not the one in mythwelcome. See https://www.mythtv.org/wiki/Mythwelcome and/or https://www.mythtv.org/wiki/ACPI_Wakeup.

comment:4 Changed 20 months ago by Jonatan Lindblad

Resolution: Unverified
Status: newclosed

It's unclear to me which of the two settings mentioned in the previous comment the reporter experienced problems with but the code looks ok to me. Feel free to reopen the ticket if you can still reproduce it after all these years and you have more information.

Note: See TracTickets for help on using tickets.