Opened 8 years ago

Closed 8 years ago

#10247 closed Bug Report - Hang/Deadlock (Upstream Bug)

Mythfrontend intermittently missing menu on first launch

Reported by: Alex Rasmussen <ar@…> Owned by:
Priority: major Milestone: unknown
Component: MythTV - General Version: 0.24.1
Severity: medium Keywords: mythfrontend missing menu
Cc: Ticket locked: no

Description

I have just installed two new ASRock Vision 3D 137B (specs here: http://www.asrock.com/nettop/overview.us.asp?Model=Vision%203D%20Series#Specifications ) frontends for my system using openSUSE 12.1 x64. When booting a unit, it will intermittently be missing the menu (only the theme backdrop) is shown. Restarting the unit enough times will eventually produce the menu.

I have two other (Zotac) units running openSUSE 11.4 against the same backend without problems.

I need the 3.1 kernel in order for my remote control to wake up the system, but I tried installing 11.4 x64 to see if openSUSE 12.1 is the problem, but the problem persists on 11.4. I have also tried both Gnome and Xfce as the window manager, with no change. As a last (desperate) attempt I have tried compiling and running the 3.2 kernel, but with no change.

The log (attached) shows what happens in mythfrontend from boot until the backdrop is shown.

Attachments (2)

mythfrontend.log (2.2 KB) - added by Alex Rasmussen <ar@…> 8 years ago.
Log file from mythfrontend
mythfrontend-hung-all.zip (24.2 KB) - added by xentac@… 8 years ago.
mythfrontend -v all output

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by Alex Rasmussen <ar@…>

Attachment: mythfrontend.log added

Log file from mythfrontend

comment:1 Changed 8 years ago by xentac@…

I am seeing the same thing, but I'm running using Zotac with Arch Linux on it. I narrowed this exact problem down to a hanging pulseaudio check. I will attach my log showing that the last thing that happens is a "ps -ae | grep pulseaudio" being launched.

If I run mythfrontend with strace, the process never hangs. Without strace it probably hangs 50-70% of the time. If I strace the hanging process, nothing is happening at all to it, it is stuck in the R state if I look at it through ps.

If I kill the forked process everything seems to work (I'm not actually running pulseaudio). Similar hangs can happen when I actually go to watch video, because the same IsPulseAudioRunning? call is made.

I don't know how else to debug this problem, can anyone offer any advice?

Changed 8 years ago by xentac@…

Attachment: mythfrontend-hung-all.zip added

mythfrontend -v all output

comment:2 Changed 8 years ago by mark@…

I'm seeing exactly the same problem, running a combined 0.24.2 FE/BE on an Asus AT5ION-T 2nd generation Ion board.

Any work-arounds?

comment:3 Changed 8 years ago by mark@…

Sorry that should say an Asus AT5IONT-I board to be precisely correct. Running with Fedora 16, latest updates.

Running the ps command in isolation never seems to hang.

comment:4 Changed 8 years ago by xentac@…

My problem was entirely nvidia driver related. Since updating to 295.20 all of my dead process problems have gone away.

comment:5 Changed 8 years ago by beirdo

Resolution: Upstream Bug
Status: newclosed
Note: See TracTickets for help on using tickets.