Opened 8 years ago

Closed 8 years ago

#10251 closed Bug Report - General (fixed)

'average' and 'maximum' words are hardcoded in the Information Centre context

Reported by: amlopezalonso@… Owned by: Nicolas Riendeau
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In order to make the spanish translation of the FE Information Centre I found the words 'maximum' and 'average' are hardcoded in the context of the machine info in the sentence '[...]using your %1 bitrate of[...]' so no proper translation can be done. Could you please fix it?

Thanks in advance, Antonio

Change History (5)

comment:1 Changed 8 years ago by Nicolas Riendeau

Status: newinfoneeded_new

Hi Antonio!

Is the message present in the translation files? At first glance it look like it is though with the word rate instead of bitrate...

(I can't check it right now since I have a problem with my be...)

Thank you!

Nicolas

comment:2 Changed 8 years ago by Nicolas Riendeau

Owner: set to Nicolas Riendeau

comment:3 Changed 8 years ago by Nicolas Riendeau

By the way, I understand it's the inserted text that has a problem, I just want to be sure I'm looking at the right place.

Thank you!

Nicolas

comment:4 in reply to:  3 Changed 8 years ago by amlopezalonso@…

Replying to knight:

Is the message present in the translation files? At first glance it look like it is though with the word >rate instead of bitrate...

Hi Nicolas!

Yes, you're right: It is rate rather than bitrate (had a typo there!).

By the way, I understand it's the inserted text that has a problem, I just want to be sure I'm >looking at the right place.

Yes, that's the problem.

Thanks! Antonio

comment:5 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: infoneeded_newclosed

This permits the translation of additionnal strings in the status screen and also change the context of others so that they are regrouped in the same context as the other status screen strings.

The problem reported in ticket #10251 was not actually caused by MythTV's code which actually handled the translation of those strings correctly, the problem is that Qt's tools were not extracting those strings when they should have. I have modified our code to work around the problem.

Sorry for the delayed commit... Figuring out the problem was easy but I couldn't test my fix because of defective hardware which has now been replaced.

Closes #10251

Branch: master Changeset: edfe1b8a03421bff2c176f5369192b9a6310afc1

Note: See TracTickets for help on using tickets.