Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10253 closed Bug Report - General (Fixed)

Cannot play songs with non-English filenames

Reported by: yiannividalis@… Owned by: paulh
Priority: minor Milestone: 0.25
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I can no longer play songs that have non English characters in the filename. I can choose them in Mythmusic but I think the player is looking for them not in utf-8 encoding.

The extract of the error is:

2012-01-11 19:35:31.030506 I  Pulse: PulseAudio suspend OK
2012-01-11 19:35:31.047850 I  AO: Resampling from 44 kHz to 48 kHz with quality medium
2012-01-11 19:35:31.048078 I  AO: Opening audio device 'default:CARD=Intel' ch 2(2) sr 48000 sf signed 32 bit reenc 0
2012-01-11 19:35:31.050463 E  ALSA: Setting hardware audio buffer size to 1536
2012-01-11 19:35:31.050761 E  ALSA: Error opening /proc/asound/card0/pcm0p/sub0/prealloc: Permission denied. 
2012-01-11 19:35:31.050773 E  ALSA: Try to manually increase audio buffer with: echo 1536 | sudo tee /proc/asound/card0/pcm0p/sub0/prealloc
2012-01-11 19:35:31.050789 E  ALSA: Unable to sufficiently increase ALSA hardware buffer size - underruns are likely
2012-01-11 19:35:41.952968 E  Could not open file (/myth/mythmusic/Ελληνικά/Μοσχολιού Βίκυ/Θα κλείσω τα μάτια.mp3)
2012-01-11 19:35:41.952979 E  AV decoder. Error: -2
2012-01-11 19:35:42.127934 I  Pulse: PulseAudio resume OK
2012-01-11 19:35:42.128032 E  Σφάλμα αποκωδικοποιητή. Could not open file  (/myth/mythmusic/Îλληνικά/ÎοÏÏÎ¿Î»Î¹Î¿Ï ÎίκÏ/Îα κλείÏÏ Ïα μάÏια.mp3)
AV decoder. Error: -2

---- " Σφάλμα αποκωδικοποιητή" means "Decoder error"
---- The "2012-01-11 19:35:41.952968 E" line reports the correct filename, but
---- the "2012-01-11 19:35:42.128032 E" line shows, well.... it's not Greek even to me ;)

MythTV Version : v0.25pre-4055-gf9f8b71-dirty
MythTV Branch : master
Network Protocol : 70
Library API : 0.25.20111207-1
QT Version : 4.8.0
Options compiled in:
 linux profile use_hidesyms using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_hdpvr using_iptv using_libfftw3 using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_v4l1 using_x11 using_xrandr using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

The new interface looks great!

Change History (4)

comment:1 Changed 8 years ago by yiannividalis@…

Before I opened the ticket I had scanned the music library twice, to make sure no folder changes were causing the problem. No results.

Since reporting it, I updated to version c29b91c, and I rescanned for music and the problem is gone.

However, the commits related to mythmusic don't mention anything about file scanner so, was it simply fixed by restarting the frontend/backend between builds? If this is the case, I was under the impression that changes to the music library were effective immediately after scanning (I hadn't restarted the frontend after scanning for music files).

Please, feel free to close this ticket.

comment:2 Changed 8 years ago by Raymond Wagner

Resolution: Fixed
Status: newclosed

Closed on reporter's request.

comment:3 Changed 8 years ago by Raymond Wagner

Milestone: unknown0.25

comment:4 Changed 8 years ago by sphery

FWIW, this was likely fixed by 14101d06a , and though your initial version info gives a later revision, something prevented it from being used (frontend didn't restart properly or something?). Now that you've restarted the frontend (again?), it's picked up the new libraries, so you're actually using the updated version. (The only reason I didn't mention the change when the ticket was opened was because the version info reported a later revision.)

Note: See TracTickets for help on using tickets.