Opened 8 years ago

Closed 8 years ago

#10261 closed Bug Report - General (fixed)

Description not tagged properly in tag no services API for getrecordedlist

Reported by: thomas@… Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When getting data from the DVR service using getrecordedlist, the description of a show isn't wrapped by <description> tags. This appears to be by design, but breaks elementtree xml processing in python.

Attachments (1)

xmlSerializer.patch (801 bytes) - added by thomas@… 8 years ago.
patch to remove the one-off processing for the description field

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by thomas@…

Attachment: xmlSerializer.patch added

patch to remove the one-off processing for the description field

comment:1 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: newclosed

XML serializer: Treat Description tag the same as any other.

I suspect this was debugging left over. I've had this patch sitting in my tree for a while but as people are now submitting it themselves I guess it's time to commit :)

Fixes #10261.

Branch: master Changeset: 95469c3f0aa267b69af02df87460f045b9610e3b

Note: See TracTickets for help on using tickets.