Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#10263 closed Patch - Bug Fix (fixed)

[PATCH] mythtranscode: Avoid a floating point exception

Reported by: Lawrence Rust <lvr@…> Owned by: beirdo
Priority: minor Milestone: 0.24.3
Component: MythTV - Mythtranscode Version: 0.24-fixes
Severity: medium Keywords: floating point exception
Cc: Ticket locked: no

Description

When mythtranscode is run with a non default profile it can throw a floating point exception during initialisation:

Program terminated with signal 8, Arithmetic exception.

422	    if ((ydiff / display_video_rect.height()) < 0.05)
(gdb) bt
    new_display_visible_rect=..., new_aspectoverride=kAspect_Off, new_adjustfill=kAdjustFill_AutoDetect_DefaultHalf)
    at videooutwindow.cpp:484
    winh=0, codec_id=kCodec_MPEG2, embedid=0) at videooutbase.cpp:419
    winw=0, winh=0, codec_id=kCodec_MPEG2, embedid=0) at videoout_null.cpp:152
    framecontrol=false, jobID=-1, fifodir=..., fifo_info=false, deleteMap=...) at transcode.cpp:716

This is caused by display_video_rect.height() being 0.

Attached patch.

Attachments (1)

0001-mythtranscode-Avoid-a-floating-point-exception.patch (1.6 KB) - added by Lawrence Rust <lvr@…> 2 years ago.

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by Lawrence Rust <lvr@…>

comment:1 Changed 2 years ago by beirdo

  • Owner set to beirdo
  • Status changed from new to assigned

comment:2 Changed 2 years ago by Github

  • Milestone changed from unknown to 0.25
  • Resolution set to fixed
  • Status changed from assigned to closed

mythtranscode: Avoid a floating point exception

Closes #10263

When mythtranscode is run with a non default profile it can
throw a flating point exception during initialisation:

Program terminated with signal 8, Arithmetic exception.

422 if ((ydiff / display_video_rect.height()) < 0.05)
(gdb) bt

new_display_visible_rect=..., new_aspectoverride=kAspect_Off, new_adjustfill=kAdjustFill_AutoDetect_DefaultHalf)
at videooutwindow.cpp:484
winh=0, codec_id=kCodec_MPEG2, embedid=0) at videooutbase.cpp:419
winw=0, winh=0, codec_id=kCodec_MPEG2, embedid=0) at videoout_null.cpp:152
framecontrol=false, jobID=-1, fifodir=..., fifo_info=false, deleteMap=...) at transcode.cpp:716

This is caused by display_video_rect.height() being 0.

Signed-off-by: Lawrence Rust <lvr@…>
Signed-off-by: Gavin Hurlbut <ghurlbut@…>

Branch: master
Changeset: 50b459419b1c79f311c2b7f56ba0fd64f8562ec8

comment:3 Changed 2 years ago by beirdo

  • Milestone changed from 0.25 to 0.24.3

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.