Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10272 closed Bug Report - General (Duplicate)

UPNP connectivity fails on MythTV update or VPN toggle

Reported by: Todd Howe <tehowe@…> Owned by: dblain
Priority: minor Milestone: unknown
Component: MythTV - UPnP Version: 0.24.1
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

MythTV backend was no longer visible to the remote frontends on my local network after the most recent update was pushed. I've observed this behavior intermittently on updates ever since I first installed MythTV and got on an update channel months ago.

This time however, I found the tool gupnp, which allows you to monitor the upnp activity on each box. As it turns out, switching my IP and network device by flipping my VPN on or off is another way to disable MythTV's uPNP functionality. (Present version 0.24.1-126). However, running the gupnp control monitor is enough to somehow kick the connection into an active state again, and all my frontend devices can see it. I have to keep the gupnp "Universal Control Point" running for the connection to stay up. However, all devices on the network can see a Windows media server running on my wife's laptop, also the guPNP "Network Light" test object works, so that rules out the router, etc.

Seems like this could be a uPNP server implementation or stability issue.

Change History (2)

comment:1 Changed 8 years ago by robertm

Resolution: Duplicate
Status: newclosed

Dupe of #10243

comment:2 Changed 8 years ago by robertm

Ticket locked: set
Note: See TracTickets for help on using tickets.