Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10284 closed Bug Report - General (Invalid)

MythVideo Parental Levels 2 and 3 Fall to 1

Reported by: Ben Carner <ben@…> Owned by: robertm
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: 0.24.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When entering MythVideo?, it takes the Parental Level code, but if the code is for Parental Level 2 or 3, it drops to Level 1, except if the code is for Level 4. That one it will take.

I have tried setting the codes for Level 2 and 3 to various easy codes, even made all the codes the same length, but if I enter a Level 2 or Level 3 code, it shows only the Level 1 movies and a green "1" in the upper left corner (I'm using MythCenter? and MythCenter?-Wide themes), just as if I had entered an invalid code.

Change History (2)

comment:1 Changed 8 years ago by robertm

Resolution: Invalid
Status: newclosed

This is as designed. Entering MythVideo? gets you the "Starting Parental Level," as set by you. Entering a higher PIN won't get you a higher level.

As it reads in the help text for the Starting Parental Level setting:

"This is the 'level' that Video starts at. Any videos with a level at or below this will be shown in the list while browsing or by default. The Parental PIN should be set to limit changing of the default level."

comment:2 Changed 8 years ago by Ben Carner <ben@…>

My "Starting Parental Level" is 4 - Highest. I set it that way because of the help text you quoted.

The idea was to be able to punch in my level 4 code and see all videos, give my 13-year-old the level 2 code and let him watch level 1 and 2 videos and give the level 3 code to my girlfriend and other adults and let them into levels 1 - 3.

According to what you're telling me, MythTV can't do that.

Note: See TracTickets for help on using tickets.