Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10314 closed Bug Report - General (Invalid)

Datatype programmatical bug in mythconverg database videometadata table

Reported by: hodosiszabolcs@… Owned by:
Priority: trivial Milestone: unknown
Component: MythTV - General Version: 0.24.1
Severity: low Keywords: database
Cc: Ticket locked: no

Description

Dear MythTV Developers,

Sadly I have to report a serious logical, design fault in the mythconverg database's videometadata table's column "releasedate".

Somehow the software in rollback/default cases uses the DATE datatype value '0000-00-00'.

I would like to warn you that 0000.00.00. is neither a valid date in java.util.Date class, nor in MySQL, nor in SQL standard, nor in any university where Database development is taugh.

I'm in a middle of a complex development for port.hu scraper for MythTV.

I wasted 3 hour of development work just because of your idiotism!

Please train your database coder.

I'm absolutely frustrated.

Sorry.

Change History (3)

comment:1 Changed 7 years ago by cpinkham

Priority: criticaltrivial
Resolution: Invalid
Severity: mediumlow
Status: newclosed

MySQL uses '0000-00-00' as a special 'zero' value to allow storing a NULL value in a Date field. It also allows a similar '00:00:00' in Time fields, and other formats specified in the official MySQL docs at bottom of the page at the link below.

http://dev.mysql.com/doc/refman/5.0/en/date-and-time-types.html

Closing ticket as invalid.

Not Sorry.

comment:2 Changed 7 years ago by beirdo

Type: Bug Report - CrashBug Report - General

comment:3 Changed 7 years ago by hodosiszabolcs@…

Any custom hack like this breaks JDBC and such APIs exotic issues, which is always a good idea to prevent with using valid values for marking NULLs (if DBMS cannot support NULLs), like 0001-01-01 (as I saw in some cases), or any date which is trivial unable to reach like 3000-01-01, but 0000-00-00 is always a pain. Maybe the program language you are using is not sensible for such cases, but would be wise to choose another value, or NULL value, if possible.

I'm trying to forward my mail to the developer of JDBC driver if I will able to investigate them.

Reading the documentation you linked it I agree this is not a bug, and I'm fine with closing of this ticket.

And sorry about my harsh voice in my previous message.

Note: See TracTickets for help on using tickets.