Opened 8 years ago

Closed 8 years ago

#10317 closed Bug Report - General (Fixed)

remote BDMV playback regression

Reported by: mythtv@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I updated my frontend and backend to https://github.com/MythTV/mythtv/commit/334f61fac6b0ccdf1f68bd824a0373f669e8a70e (the latest mythbuntu build) and it would seem that the playback of BDMV/ disc structures stored on a remote backend has been broken by a commit within the last week or so.

The backend states:

2012-02-09 03:02:37.209806 I [20766] ProcessRequest? mainserver.cpp:1474 (HandleAnnounce?) - MainServer::HandleAnnounce? FileTransfer? 2012-02-09 03:02:37.209813 I [20766] ProcessRequest? mainserver.cpp:1476 (HandleAnnounce?) - adding: ubuntu as a remote file transfer 2012-02-09 03:02:37.210799 E [20766] ProcessRequest? mainserver.cpp:1558 (HandleAnnounce?) - FileTransfer? filename '/media/disk2/VideosBD/Avatar' is actually a directory, cannot transfer.

while the frontend reports 2012-02-09 03:02:37.165542 E RemoteFile::openSocket(file data socket): Failed to open socket, error was filetransfer_filename_is_a_directory 2012-02-09 03:02:37.167770 E FileRingBuf?(myth://Videos@192.168.1.72:6543/BD/Avatar): RingBuffer::RingBuffer?(): Failed to open remote file (myth://Videos@192.168.1.72:6543/BD/Avatar)

I believe the last commit I was running with the correct behavior was https://github.com/MythTV/mythtv/commit/c465cb5827bb36e2bdc67692e962dd5913482f2b but I cannot be totally sure.

Change History (4)

comment:1 Changed 8 years ago by mythtv@…

I believe this may be an issue with the backend, as I built an older version of the frontend and get exactly the same behaviour - I will try going back further to be sure; I am not currently in a position to be able to build/test an older version of the backend, so I am unable to verify exactly when the regression was introduced.

comment:2 Changed 8 years ago by mythtv@…

After further testing, this is not exclusive to BDMV media; it also occurs with DVDs saved as decrypted VIDEO_TS folders.

comment:3 Changed 8 years ago by mythtv@…

I can confirm that a fix suggested by stichnot on IRC fixes this problem. This problem occurs due to the deletion of gCoreContext->SendReceiveStringList?(strlist); in the commit https://github.com/MythTV/mythtv/commit/adca89e6f

comment:4 Changed 8 years ago by danielk

Resolution: Fixed
Status: newclosed

Fixed by [4b8bf380c]

Note: See TracTickets for help on using tickets.