Opened 7 years ago

Closed 7 years ago

#10338 closed Patch - Bug Fix (fixed)

mythmetadatalookup moves inetrefs from recording to rule to unrelated recording for e.g. people searches

Reported by: dekarl@… Owned by: robertm
Priority: minor Milestone: 0.25
Component: MythTV - Mythmetadatalookup Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

while testing out the fix for generic episodes I let the dangerous lookup run and ended up with inetrefs on my people searches (which by principle cannot be matched to one specific inetref)

I propose to only push the inetref back to the recording rule when its not a search rule

Attachments (1)

0001-only-save-inetref-for-recordingrules-that-do-not-sea.patch (1.3 KB) - added by dekarl@… 7 years ago.
suggested fix (untested as of now)

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by dekarl@…

suggested fix (untested as of now)

comment:1 Changed 7 years ago by robertm

Status: newinfoneeded_new

At first glance, I don't see a problem with this fix. Can you please test against your material and report back?

comment:2 Changed 7 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: infoneeded_newclosed

Do not copy inetrefs from rule -> recording when the rule is a search.

Thanks to Karl Deitz for the report and suggested solution. It appears to work fine from limited testing. If you find that the problem is still present for you, please reopen the ticket.

Fixes #10338.

Branch: master Changeset: c60f33147e9a556dbc8392c791eaa339f3b3a2f5

Note: See TracTickets for help on using tickets.