Opened 7 years ago

Last modified 4 years ago

#10345 new Bug Report - General

Adding new card problem

Reported by: yiannividalis@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Mythtv-setup Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I deleted all cards from mythtv, then I tried to re-add them. The first type of card available in the mythtv-setup wizard is V4L. I have two /dev/video[12] devices, 1 is a terratec saa7134 and 2 is a hdpvr. The device identification in mythtv-setup was blank upon entering the wizard, and below was the message "could not open card" or similar - this is from memory, sorry I cannot be more specific. Typing "/dev/video0" works, though, and the card description appears as "Cinergy Terratec etc".

Adding a dvb-s card with a 2 lnb switch shows problems when I add the input connections later on: The program keeps offering new input connections even when I chose just 2 simultanneous recordings. Shouldn't this be at most 4 virtual cards? Also, in the new cardinput table, the default inputname value for the dvb-s card is "Television" instead of "DVBinput" that was present before deleting the cards.

The backend refuses to run with the dvb-s card added, and shows messages like "Are you sure you added all input connections ..."

The backend works ok with just the analog and hdpvr connected.

Adding a dvb-t card with 4 simultanneous connections only adds one cardinput.

Also, during my last full satellite scan - this was some time ago - no new channels were reported found if I let the scan finish, although I could see them in the scanner being found. To add them, I had to manually interrupt the scanning process.

MythTV Version : v0.25pre-4541-g94d27c6-dirty MythTV Branch : master Network Protocol : 72 Library API : 0.25.20120212-5 QT Version : 4.7.2 Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_hdpvr using_iptv using_ivtv using_libcrypto using_libfftw3 using_libxml2 using_libudf using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_v4l1 using_x11 using_xrandr using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2 using_libudf

I have no logs, but I think the situation is reproducible.

Best regards,

Yianni.

Change History (2)

comment:1 Changed 7 years ago by danielk

Resolution: Invalid
Status: newclosed

It sounds like you made some mistakes during setup please seek assistance on the mythtv-users mailing list.

comment:2 Changed 4 years ago by pstump@…

Resolution: Invalid
Status: closednew

I had this same problem with my HD PVR. I did a fresh install of Mythbuntu 14.04 on a new machine while my current 12.04 box was working. I could not get recordings or live tv to go past 20% or 60% lock. Note a channel change error (direct_http2.pl) would cause a signal lock of 0%.

Nothing I did would work. I found this in a thread and manually changed my database after comparing the two. This is indeed the cause of the issue. I changed "inputname" in CardInput? to "Composite" and after a reboot it immediately started working. For the HDPVR the I don't know of a "Television" input setting, the settings are 0=composite, 1,=svideo, 2=composite. This feels like a valid bug to me. It seems like there is an issue causing it to default to "Television".

As a note, I am running the latest firmware for the HDPVRs on all of them.

I have used myth since the early days (compiling :) ) so I know my way around it. Not saying I didn't do something wrong during setup, but I have been setting it up for a long time and did the same thing over and over again. I have never had this issue in the past. If it is a setup option I would say that it is not an obvious one and people who are new will make it and just give up. This took me 2 days (of solid work) to figure it out.

Thanks to those who reported it. My wife (who has not had tv for 3 days) and I thank you. It helped me get TV going again!!!

Patrick

Note: See TracTickets for help on using tickets.