Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 2 years ago

#10377 closed Bug Report - General (fixed)

LiveTV: Same source different multiplex channel changes fail

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When you have four recorders defined like so:

[1] /dev/dvb/adapter0
[2] /dev/dvb/adapter0
[3] /dev/dvb/adapter1
[4] /dev/dvb/adapter1

And they are all connected to the same video source.
And recorder 1 is recording something on multiplex 1
And you are in LiveTV in recorder 2
And you switch to a channel on multiplex 2
And neither 3 or 4 is busy OR one is busy but is on multiplex 2

Then the channel change will fail.

Attachments (2)

10377-v1.patch (5.4 KB) - added by danielk 2 years ago.
10377-v3.patch (10.0 KB) - added by danielk 2 years ago.
Tell switch cards which input we need.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by danielk

comment:1 Changed 2 years ago by danielk

The patch fixes the problem described, but I'm not sure if it breaks anything else yet.

comment:2 Changed 2 years ago by skd5aner <skd5aner@…>

See #4989 and #7164 which reference the same symptoms after the implementation of multi-rec. (thanks danielk for taking another look)

Changed 2 years ago by danielk

Tell switch cards which input we need.

comment:3 Changed 2 years ago by jyavenard

Confirm that it works as intended.

Perfect.

comment:4 Changed 2 years ago by Github

Refs #10377. Some logging fixes. (VB_PLAYBACK->VB_CHANNEL).

Branch: master
Changeset: 593d24b544e2127db420a1be07eb690f649e2f64

comment:5 Changed 2 years ago by Github

  • Resolution set to fixed
  • Status changed from new to closed

Fixes #10377. Prevent getting "stuck on a mux".

When multiple digital cards share a video source we can get stuck to a mux in Live TV. This fixes that bug. See ticket for steps to reproduce.

Branch: master
Changeset: 21784cef55b4cf45268fde2afc839c4b80aab8e1

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.