Opened 8 years ago

Closed 6 years ago

#10378 closed Bug Report - Crash (Works for me)

LiveTV FE segfault during channel change

Reported by: warpme@… Owned by: JYA
Priority: major Milestone: 0.27
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords: LiveTV
Cc: Ticket locked: no

Description

Hi, Per http://www.gossamer-threads.com/lists/mythtv/users/504648#504757 I was finally able to get trace for segfault during LiveTV channel change. I'm on mythfrontend version: master 20120224-gd59f4f4. Frontend log is without increased verbosity as with increased one I can't get segfault (looks like timing issue).

Attachments (1)

trace.txt (58.0 KB) - added by warpme@… 8 years ago.
FE segfault trace

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by warpme@…

Attachment: trace.txt added

FE segfault trace

comment:3 Changed 6 years ago by stuartm

Milestone: unknown0.27
Owner: set to Jim Stichnoth
Priority: minorblocker
Status: newassigned

comment:4 Changed 6 years ago by stuartm

Status: assignedinfoneeded

This segfault is in ffmpeg, there have been a few ffmpeg resyncs since then so this may be fixed. Can you reproduce this with 0.27?

comment:5 Changed 6 years ago by stuartm

Owner: changed from Jim Stichnoth to JYA

comment:6 Changed 6 years ago by JYA

the crash is in mpegts.c ; which is unique to mythtv and hasn't been touched in years...

I know nothing with mpegts unfortunately...

comment:7 Changed 6 years ago by JYA

Priority: blockermajor

comment:8 Changed 6 years ago by warpme@…

Hi. I'm on current 0.27 and problem seems to be fixed by 0.27. Please close ticket :-)

comment:9 Changed 6 years ago by Raymond Wagner

Resolution: Works for me
Status: infoneededclosed

Reported fixed.

Note: See TracTickets for help on using tickets.