Opened 14 years ago

Closed 14 years ago

#1039 closed defect (fixed)

first tuning to non-default DiSEqC input of a new card in LiveTV fails

Reported by: pstehlik@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

My setup: channel 1 = bttv (card 1, sourceid = 1); channels 6,8 = DVB-S DiSEqC input 1 (card 2, sourceid = 2); channel 9 = DVB-S DiSEqC input 2 (card 2, sourceid = 3).

The problem is that when asking for channel 9 while LiveTV is tuned to another card the MythTV correctly finds out that it should switch to card 2 but then ignores the sourceid/DiSEqC setup somehow and tunes the last used channel on the wrong DiSEqC input instead.

Timeline:

  • 12:55:00 entered Live TV - bttv channel 1
  • 12:55:30 asked for channel 8 - got channel 8
  • 12:56:30 asked for channel 9 and since I am on the card 2 already I get the channel 9 correctly
  • 12:57:00 switching back to bttv by changing to channel 1
  • 12:57:30 trying to get channel 9 (=switching to card 2) but getting channel 8 -> PROBLEM. Probably got ch.8 because it was last used channel on card 2/sourceid 2 - my choice of channel 9 was ignored completely
  • 12:58:00 changing to channel 6 to make the 6 last used channel on card 2/sourceid 2
  • 12:58:30 changing to channel 9 to make the 9 last used channel on card 2/sourceid 3
  • 12:59:00 going back to bttv
  • 12:59:30 asking for channel 9 (=switching to card 2) but getting channel 6 -> PROBLEM. Probably got ch.6 because it was last used channel on card 2/sourceid 2 - my choice of channel 9 was ignored completely

Attachments (2)

frontend3.log.gz (39.5 KB) - added by pstehlik@… 14 years ago.
backend3.log.gz (72.4 KB) - added by pstehlik@… 14 years ago.

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by pstehlik@…

Attachment: frontend3.log.gz added

Changed 14 years ago by pstehlik@…

Attachment: backend3.log.gz added

comment:1 Changed 14 years ago by danielk

Milestone: unknown
Owner: changed from Isaac Richards to danielk
Version: head

comment:2 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [8641]) Fixes #1039.

Makes starting input match starting channel.

Note: See TracTickets for help on using tickets.