Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 19 months ago

#10390 closed Patch - Feature (fixed)

Have an attribute so MythUIWebBrowser never takes focues

Reported by: killerkiwi2005@… Owned by: stuartm
Priority: minor Milestone: 0.27
Component: MythTV - User Interface Library Version: Master Head
Severity: medium Keywords: MythUIWebBrowser focus
Cc: Ticket locked: no

Description

Id like to use the MythUIWebBrowser to show info on the menu screen (weather details, news ticker etc) but currently the widget takes the focus. Would be nice to be able to tell MythUI that the widget should never take focus

Attribute Suggestions :

focusorder="-1" - -1 meaing never focus
or
allowfocus="0" - defaults to true

Attachments (0)

Change History (7)

comment:1 Changed 2 years ago by beirdo

  • Resolution set to Invalid
  • Status changed from new to closed

This is a feature request, not a bug. Sorry.

comment:2 Changed 2 years ago by killerkiwi2005@…

Sorry, where do I enter requests?

comment:3 Changed 2 years ago by killerkiwi2005@…

NM I should read the whole help page, apologies for the noise

comment:4 Changed 2 years ago by killerkiwi2005@…

  • Resolution Invalid deleted
  • Status changed from closed to new

Heres code to make this change

As I understand it that makes this a valid ticket?

https://github.com/MythTV/mythtv/pull/15

comment:5 Changed 2 years ago by stuartm

  • Milestone changed from 0.25 to 0.26
  • Type changed from Bug Report - General to Patch - Feature
  • Version changed from Unspecified to Master Head

comment:6 Changed 19 months ago by kenni

  • Milestone changed from 0.26 to 0.27

comment:7 Changed 19 months ago by Stuart Morgan <smorgan@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 9059a4e08d9c48fa91a8d251b3d3329e195ca48c/mythtv:

Add an 'acceptsfocus' tag to the <webbrowser> widget. Fixes #10390

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.