Opened 8 years ago

Closed 8 years ago

#10467 closed Bug Report - General (fixed)

Standby countdown NOT suspended by video playback.

Reported by: blazej.lewcio@… Owned by: stuartm
Priority: minor Milestone: 0.25
Component: MythTV - Mythwelcome & Mythshutdown Version: Master Head
Severity: medium Keywords: standby countdown
Cc: Ticket locked: no

Description

According to the option description, the "idle time before entering standby mode" counter supposes to be suspended when video playback is active. In my setup it is not the case, and mythfrontend enters the standby mode, when I watch Live TV.

Tested on master branch, commit 9c4e7fd75 (from MAR 15). More specific info/logs can be provided on request.

Attachments (1)

standby.log (12.2 KB) - added by anonymous 8 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by stuartm

Milestone: unknown0.25
Owner: set to stuartm
Status: newaccepted
Version: UnspecifiedMaster Head

comment:2 Changed 8 years ago by Github

Don't use the PLAYBACK_START/PLAYBACK_END events to pause the idle timer, the problem is that MythMusic unpauses the timer when it recieves the PLAYBACK_START event because it's just stopped music playback. There's no simple way around this if we continue to use the events, so just call PauseIdleTimer?() directly instead. Refs #10467

Branch: master Changeset: 85ac156239c9e47fa042cfc47f8925ce0a25d575

comment:3 Changed 8 years ago by stuartm

Can you test this again with master? I'm unsure how this would relate to your problem except that the only explanation for the idle timer kicking in during playback is that the PLAYBACK_START event wasn't received for some reason on your system (still highly unlikely). Now that we're calling PauseIdleTimer?() directly it should at least rule out that possibility.

I've added some debugging, so logs from the latest master would be useful, from the point that you start livetv to the time that it enters standby.

comment:4 Changed 8 years ago by stuartm

Status: acceptedinfoneeded

comment:5 Changed 8 years ago by blazej.lewcio@…

The problem still persists in 85ac15623. Interestingly, I only observe it with LiveTV, no problems when watching videos(, so far). Log attached.

Changed 8 years ago by anonymous

Attachment: standby.log added

comment:6 Changed 8 years ago by Github

Resolution: fixed
Status: infoneededclosed

Only restart the idle timer if it was active to begin with. This was broken by ad7ee3fd. Fixes #10467

Branch: master Changeset: e1bf100b4dfc6fc9eef66316e67bbc3bb46d82a2

Note: See TracTickets for help on using tickets.