Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1047 closed defect (fixed)

double escape from watch recordings menu crashed frontend

Reported by: ben@… Owned by: cpinkham
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: play recordings crash escape
Cc: Ticket locked: no

Description

If I hit escape it takes quite a long time to leave the recordings menu, so sometime I am not sure if i have pressed it or not, but if I press it a second time the frontend crashes. Doing a ps -x shows its still there but the graphical part has gone, and it needs to be killed so that it can be started again.

I notice that if you press the left arrow multiple times it does not crash, only on esc. Its repeatable every time. I am runnins the latest svn (8624).

The crash seems to put nothing into the logfile even with -v all

Leaving recordings does put stuff in the log file (with or without the double esc. I guess this is why its takes a while to leave):-

2006-01-16 17:43:11.900 NVP: Exited decoder loop.

2006-01-16 17:43:11.901 MSqlQuery: SELECT editing FROM recorded WHERE chanid = '1024' AND starttime = '2006-01-07T19:30:00' ;

2006-01-16 17:43:11.901 MSqlQuery: SELECT status FROM jobqueue WHERE type = 2 AND chanid = '1024' AND starttime = '2006-01-07T19:30:00';

2006-01-16 17:43:11.902 write -> 14 864 QUERY_GENPIXMAP[]:[]Billion Dollar Brain[]:[][]:[]Espionage thriller, the third in a series based on Len Deighton's popular spy novels. A former intelligence agent is persuaded to return to work, accepting an assignment to deliver a mysterious package to Helsinki. But when he arrives in Finland, he meets an old acquaintance, an ex-CIA man now involved with a billionaire who plans to destroy Communism in Eastern Europe with his own private army.[]:[]film[]:[]1024[]:[]9[]:[]BBC 4[]:[]BBC4[]:[]/data/video/record/1024_20060107193000_20060107211500.nuv[]:[]1[]:[]-1453224008[]:[]1136662200[]:[]1136668500[]:[]0[]:[]0[]:[]0[]:[]mythtv.internal.vanilla.net[]:[]0[]:[]0[]:[]0[]:[]0[]:[]-3[]:[]0[]:[]0[]:[]0[]:[]0[]:[]1136662200[]:[]1136668500[]:[]0[]:[]5[]:[]Default[]:[]0[]:[][]:[]15644654[]:[]MV15644654[]:[]1136896505[]:[]0.000000[]:[]1136592000[]:[]1[]:[]Default

2006-01-16 17:43:11.934 ~VideoOutputNull?()

2006-01-16 17:43:12.023 read <- 14 3 BAD

Then from the select its repeating a further 2 times.

If I can be of any more help please let me know what you would like to see.

Ben

Attachments (3)

gdb.txt (12.6 KB) - added by ben@… 14 years ago.
Backtrace
gdb2.txt (77.8 KB) - added by stutty@… 14 years ago.
Second incidence of segmentation fault
myth_last.log (14.6 KB) - added by stutty@… 14 years ago.
Second incidence of segmentation fault - myth.log

Download all attachments as: .zip

Change History (13)

comment:1 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

Backtraces are required when reporting crashes.

Changed 14 years ago by ben@…

Attachment: gdb.txt added

Backtrace

comment:2 Changed 14 years ago by anonymous

Resolution: invalid
Status: closedreopened

Added backtrace, please let me know if there is anything else I can do to help.

Changed 14 years ago by stutty@…

Attachment: gdb2.txt added

Second incidence of segmentation fault

comment:3 Changed 14 years ago by stutty@…

This may be a slightly different fault, basically on exiting the watch recordings screen I occassionally get a seg fault - I'm using a remote but I'm pretty sure I only press the escape key once.

Please ignore the initial part of the trace - several prior runs of gdb, last run start at line 1461.

Changed 14 years ago by stutty@…

Attachment: myth_last.log added

Second incidence of segmentation fault - myth.log

comment:4 Changed 14 years ago by torbjorn.jansson@…

i just wanted to say that the backtrace in file gdb2.txt attached by stutty@… looks similar to my ticket in #1078

it looks like both of them involvs QMutex::lock and PreviewGenerator::disconnectSafe so they could be the same problem.

comment:5 Changed 14 years ago by Dave

I have a similar issue but the frontend doesn't crash. A quick double escape from watching a recording should take you back to the media menu, but it deletes the window. The process is still running.

comment:6 Changed 14 years ago by tephra@…

Yep same here, Its has been like that since very early on (ie just after cvs->svn)

If someone tells me what todo i can get a debug of it.

Cheers D.

comment:7 Changed 14 years ago by danielk

Resolution: duplicate
Status: reopenedclosed

It looks more like #1075 to me. I'm closing this as a duplicate of that one.

comment:8 Changed 14 years ago by ben@…

Resolution: duplicate
Status: closedreopened

HI,

I am reopening this as the 1075 fix makes no difference.

Done a distclaen of course, currently running :-

[mythtv@mythtv ~]$ mythbackend --version

Library API version: 0.19.20060121-2 Source code version: 8733M Options compiled in:

linux release using_oss using_alsa using_arts using_dbox2 using_lirc using_joystick_menu using_dvb using_dvb_eit using_x11 using_xv using_xrandr using_frontend using_backend

comment:9 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

Ben, it appears you have a completely different problem now.

Please create a separate ticket and attach a proper backtrace. Please read the TicketHowTo, especially the link to how to create a backtrace; your latest one is missing the debugging symbols.

comment:10 Changed 14 years ago by danielk

(In [8745]) References #1047.

everStartedVideo was not being set to false once the decoder thread was joined. This sets it and also renames the variable to 'previewThreadRunning' which is more descriptive.

Note: See TracTickets for help on using tickets.