Opened 7 years ago

Last modified 11 months ago

#10480 new Bug Report - General

Downloading channel icons via backend fails

Reported by: ac00perw@… Owned by: cpinkham
Priority: minor Milestone: 29.2
Component: MythTV - Mythtv-setup Version: 0.24.2
Severity: medium Keywords: channel icons
Cc: Ticket locked: no

Description

Attempting to download icons stores the first 25 or so and then stops. Seems to make it up to K but not sure if it's related to the alphabet.

Also searching for specific icons doesn't appear to bring up a full list of possibilities as well.

Change History (18)

comment:1 Changed 7 years ago by stuartm

Milestone: unknown0.25

We're going to need more information than this. A detailed Step by step account of what you were doing, what you expect to happen and specifically the searches which don't return the expected results.

For performances reasons we only show 300 results, I suspect that's the second bit you're describing but that's not a bug. If the result you want isn't in the first 300 results then it's probably not there at all.

comment:2 Changed 7 years ago by ac00perw@…

I manually cleared out my icons and from myth backend went to channel editor and chose 'Icon Download' and selected 'Download all Icons.' The import works for all icons up to 'Investigation_Discovery_us.jpg' but does not download the rest of the icons. Not sure which log file I should be seeking out to give you more info. Seemed like the backend log didn't give me anything useful.

comment:3 Changed 7 years ago by beirdo

Component: MythTV - GeneralMythTV - Mythtv-setup
Owner: set to stuartm
Status: newassigned

comment:4 Changed 7 years ago by stuartm

Milestone: 0.250.25.1

comment:5 Changed 6 years ago by Raymond Wagner

Milestone: 0.25.10.26

comment:6 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: 0.260.26.1

comment:7 Changed 6 years ago by stuartm

Status: assignedinfoneeded

I'm not able to reproduce this, which makes it much harder to debug. We'd need the mythtv-setup log with -v network,file

comment:8 Changed 6 years ago by stuartm

Resolution: Need more Info
Status: infoneededclosed

comment:9 Changed 6 years ago by jvdillon@…

I also have this problem and let me tell you its WICKED annoying.

I actually see two problems which I'm fairly certain are related.

The first problem is essentially as op describes. Suppose I search for an icon that returns many results, say "MTV". The first few icons download and the remainder will not. Then suppose you search for "VH1". None of these logos will download--and indeed the log indicates MTV logos are still downloading.

I think the problem is that the current implementation wget's the files on every repaint and lyngsat.com treats these repeated/numerous requests as hammering. This brings me to problem #2 which I think is the culprit.

It looks to me that at one point Qt (or whatever windowing libs are used) did not trigger a full repaint on every window redraw (ie selecting a different logo). At some point this behavior changed, meaning that every reselection triggers another wget of every relevant image. Obviously this is bad.

This bug essentially makes the manual icon selection impossible. I've resorted to manual dowload and editing mythconverg myself.

comment:10 Changed 6 years ago by jvdillon@…

I should mention that I'm using 0.26/ppa (ubuntu 12.04) with mythbuntu theme. I don't have any logs atm but I seriously doubt they'd help as I already looked through them. I'm sure the problem is that cached logos are not used but rather excessive and unecessary wget. (Which is a bug in and of itself anyway.)

comment:11 Changed 6 years ago by stuartm

Owner: changed from stuartm to cpinkham

comment:12 Changed 6 years ago by stuartm

Resolution: Need more Info
Status: closednew

comment:13 Changed 5 years ago by paulh

Milestone: 0.26.10.28

comment:14 Changed 3 years ago by Stuart Auchterlonie

Milestone: 0.280.29

Moving to 0.29

comment:15 Changed 3 years ago by Stuart Auchterlonie

Milestone: 0.2929.0

Milestone renamed

comment:16 Changed 13 months ago by Stuart Auchterlonie

Milestone: 29.029.1

comment:17 Changed 11 months ago by Stuart Auchterlonie

Milestone: 29.10.28.2

Moving remaining open tickets to 0.28.2 milestone

comment:18 Changed 11 months ago by Stuart Auchterlonie

Milestone: 0.28.229.2

Moving remaining open tickets to 29.2 milestone

Note: See TracTickets for help on using tickets.