Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10508 closed Bug Report - General (fixed)

mythweb should depend on php 5.3

Reported by: Alec M <alecm@…> Owned by: Raymond Wagner
Priority: minor Milestone: 0.25.1
Component: Packaging Version: 0.24.2
Severity: medium Keywords:
Cc: Ticket locked: no


Since mythweb does not work with PHP 5.4, it should depend on a version less than 5.4.


Change History (7)

comment:1 Changed 9 years ago by Raymond Wagner

Owner: set to Raymond Wagner
Status: newaccepted

comment:2 Changed 9 years ago by Raymond Wagner

Milestone: unknown0.25
Resolution: Fixed
Status: acceptedclosed

Fixed by 2caa47f0ad4728.

comment:3 Changed 9 years ago by Alec M <alecm@…>

Resolution: Fixed
Status: closednew


You made a typo: it should either be ">=dev-lang/php-5.3" or "dev-lang/php:5.3" - not "=dev-lang/php-5.3".

In fact, using the slot would probably be much cleaner:

    || ( dev-lang/php:5.3[curl,json,mysql,session,posix]
        <dev-lang/php-5.3[spl,pcre] )

comment:4 Changed 9 years ago by Dave Sp <davespmyth@…>

If the patches in ticket 10504 address the root cause of the problem, is the change in this ticket necessary?

comment:5 Changed 9 years ago by beirdo

Milestone: 0.25unknown

comment:6 Changed 9 years ago by Raymond Wagner <rwagner@…>

Resolution: fixed
Status: newclosed

In 7818813af83d02c7282d50c2653f57f101deaf75/packaging:

Fix Gentoo ebuilds for MythWeb

This corrects the invalid syntax for PHP selection, instead using slots
to depend on PHP 5.3, while not breaking other applications that may be
using a different version. This also includes new ebuilds for 0.25 and
developmental 0.26.

Fixes #10508
Fixes #10769

comment:7 Changed 9 years ago by Raymond Wagner

Milestone: unknown0.25.1
Note: See TracTickets for help on using tickets.