Opened 8 years ago

Closed 8 years ago

#10532 closed Bug Report - General (Duplicate)

Gentoo: mythgame fails to install

Reported by: christopher.j.reeves@… Owned by: robertm
Priority: minor Milestone: 0.25
Component: Plugin - MythGame Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The errors below appear to be related to the following web link:

https://bugs.gentoo.org/show_bug.cgi?id=383179

Emerging (1 of 1) media-plugins/mythgame-0.25_pre20120329 from mythtv

  • mythtv-0.25_pre20120329.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]

Unpacking source... Unpacking mythtv-0.25_pre20120329.tar.gz to /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work Source unpacked in /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work Preparing source in /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins ... Source prepared. Configuring source in /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins ...

./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --compile-type=release --disable-mytharchive --disable-mythbrowser --disable-mythgallery --enable-mythgame --disable-mythmusic --disable-mythnetvision --disable-mythnews --disable-mythweather --disable-mythzoneminder

Configuration settings:

qmake /usr/bin/qmake

MythArchive? plugin will not be built MythBrowser? plugin will not be built MythGallery plugin will not be built MythGame? plugin will be built MythMusic plugin will not be built MythNetvision? plugin will not be built MythNews? plugin will not be built MythWeather? plugin will not be built MythZoneMinder? plugin will not be built

Source configured. Compiling source in /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins ...

make -j3 cd cleanup/ && make -f Makefile cd mythgame/ && /usr/bin/qmake /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/mythgame.pro -o Makefile make[1]: Entering directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/cleanup' make[1]: Nothing to be done for `check'. make[1]: Leaving directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/cleanup' cd mythgame/ && make -f Makefile make[1]: Entering directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame' cd mythgame/ && /usr/bin/qmake /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/mythgame/mythgame.pro -o Makefile cd theme/ && /usr/bin/qmake /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/theme/theme.pro -o Makefile cd i18n/ && /usr/bin/qmake /tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/i18n/i18n.pro -o Makefile cd i18n/ && make -f Makefile make[2]: Entering directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/i18n' gcc -c -pipe -march=k8-sse3 -std=c99 -DNDEBUG -fomit-frame-pointer -fPIC -pthread -g -Wall -Wno-parentheses -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -Wcast-qual -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -O3 -fno-math-errno -fno-signed-zeros -fno-tree-vectorize -g -Wall -W -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -D_FILE_OFFSET_BITS=64 -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include -I/usr/include -I/usr -I/usr/include -I/usr/include/libxml2 -o dummy.o dummy.c cd theme/ && make -f Makefile make[2]: Entering directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/theme' gcc -c -pipe -march=k8-sse3 -std=c99 -DNDEBUG -fomit-frame-pointer -fPIC -pthread -g -Wall -Wno-parentheses -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -Wcast-qual -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -O3 -fno-math-errno -fno-signed-zeros -fno-tree-vectorize -g -Wall -W -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -D_FILE_OFFSET_BITS=64 -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include -I/usr/include -I/usr -I/usr/include -I/usr/include/libxml2 -o themedummy.o ../../themedummy.c g++ -o i18n dummy.o -L/usr/lib64 g++ -o themenop themedummy.o -L/usr/lib64 cd mythgame/ && make -f Makefile make[2]: Entering directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/mythgame' g++ -c -pipe -march=k8-sse3 -DNDEBUG -fomit-frame-pointer -fPIC -pthread -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -DSTDC_LIMIT_MACROS -O3 -fvisibility-inlines-hidden -Wmissing-declarations -fvisibility=hidden -g -D_REENTRANT -Wall -W -DPIC -fPIC -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -D_FILE_OFFSET_BITS=64 -DMPLUGIN_API -DQT_PLUGIN -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr/include -I/usr/include -I/usr -I/usr/include -I/usr/include/libxml2 -I/usr/include/mythtv -I/usr/include/mythtv/libmythbase -I/usr/include/mythtv/libmythui -I/usr/include/mythtv/libmyth -I/usr/X11R6/include -I. -o main.o main.cpp

{ test -n "" && DESTDIR=""
DESTDIR=.; } && test $(gdb --version | sed -e 's,[0-9]\+\([0-9]\)\.\([0-9]\).*,\1\2,;q') -gt 72 && gdb --nx --batch --quiet -ex 'set confirm off' -ex "save gdb-index $DESTDIR" -ex quit 'i18n' && test -f i18n.gdb-index && objcopy --add-section '.gdb_index=i18n.gdb-index' --set-section-flags '.gdb_index=readonly' 'i18n' 'i18n' && rm -f i18n.gdb-index true

/bin/sh: gdb: command not found /bin/sh: line 0: test: -gt: unary operator expected make[2]: Leaving directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/i18n' g++ -c -pipe -march=k8-sse3 -DNDEBUG -fomit-frame-pointer -fPIC -pthread -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -DSTDC_LIMIT_MACROS -O3 -fvisibility-inlines-hidden -Wmissing-declarations -fvisibility=hidden -g -D_REENTRANT -Wall -W -DPIC -fPIC -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -D_FILE_OFFSET_BITS=64 -DMPLUGIN_API -DQT_PLUGIN -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr/include -I/usr/include -I/usr -I/usr/include -I/usr/include/libxml2 -I/usr/include/mythtv -I/usr/include/mythtv/libmythbase -I/usr/include/mythtv/libmythui -I/usr/include/mythtv/libmyth -I/usr/X11R6/include -I. -o gamehandler.o gamehandler.cpp

{ test -n "" && DESTDIR=""
DESTDIR=.; } && test $(gdb --version | sed -e 's,[0-9]\+\([0-9]\)\.\([0-9]\).*,\1\2,;q') -gt 72 && gdb --nx --batch --quiet -ex 'set confirm off' -ex "save gdb-index $DESTDIR" -ex quit 'themenop' && test -f themenop.gdb-index && objcopy --add-section '.gdb_index=themenop.gdb-index' --set-section-flags '.gdb_index=readonly' 'themenop' 'themenop' && rm -f themenop.gdb-index true

/bin/sh: gdb: command not found /bin/sh: line 0: test: -gt: unary operator expected make[2]: Leaving directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/theme' g++ -c -pipe -march=k8-sse3 -DNDEBUG -fomit-frame-pointer -fPIC -pthread -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -DSTDC_LIMIT_MACROS -O3 -fvisibility-inlines-hidden -Wmissing-declarations -fvisibility=hidden -g -D_REENTRANT -Wall -W -DPIC -fPIC -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -D_FILE_OFFSET_BITS=64 -DMPLUGIN_API -DQT_PLUGIN -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr/include -I/usr/include -I/usr -I/usr/include -I/usr/include/libxml2 -I/usr/include/mythtv -I/usr/include/mythtv/libmythbase -I/usr/include/mythtv/libmythui -I/usr/include/mythtv/libmyth -I/usr/X11R6/include -I. -o rominfo.o rominfo.cpp In file included from rom_metadata.h:7:0,

from gamehandler.h:12, from gamehandler.cpp:2:

unzip.h:114:45: error: expected initializer before 'OF' unzip.h:127:32: error: expected initializer before 'OF' unzip.h:138:29: error: expected initializer before 'OF' unzip.h:145:37: error: expected initializer before 'OF' unzip.h:153:40: error: expected initializer before 'OF' unzip.h:166:37: error: expected initializer before 'OF' unzip.h:172:36: error: expected initializer before 'OF' unzip.h:179:34: error: expected initializer before 'OF' unzip.h:192:42: error: expected initializer before 'OF' unzip.h:218:39: error: expected initializer before 'OF' unzip.h:224:40: error: expected initializer before 'OF' unzip.h:230:39: error: expected initializer before 'OF' unzip.h:244:32: error: expected initializer before 'OF' unzip.h:249:27: error: expected initializer before 'OF' unzip.h:254:42: error: expected initializer before 'OF' In file included from rom_metadata.h:7:0,

from gamehandler.h:12, from main.cpp:10:

unzip.h:114:45: error: expected initializer before 'OF' unzip.h:127:32: error: expected initializer before 'OF' unzip.h:138:29: error: expected initializer before 'OF' unzip.h:145:37: error: expected initializer before 'OF' unzip.h:153:40: error: expected initializer before 'OF' unzip.h:166:37: error: expected initializer before 'OF' unzip.h:172:36: error: expected initializer before 'OF' unzip.h:179:34: error: expected initializer before 'OF' unzip.h:192:42: error: expected initializer before 'OF' unzip.h:218:39: error: expected initializer before 'OF' unzip.h:224:40: error: expected initializer before 'OF' unzip.h:230:39: error: expected initializer before 'OF' unzip.h:244:32: error: expected initializer before 'OF' unzip.h:249:27: error: expected initializer before 'OF' unzip.h:254:42: error: expected initializer before 'OF' make[2]: * [gamehandler.o] Error 1 make[2]: * Waiting for unfinished jobs.... make[2]: * [main.o] Error 1 make[2]: Leaving directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame/mythgame' make[1]: * [sub-mythgame-make_default] Error 2 make[1]: Leaving directory `/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins/mythgame' make: * [sub-mythgame-make_default] Error 2 emake failed

  • ERROR: media-plugins/mythgame-0.25_pre20120329 failed (compile phase):
  • make failed to compile
  • Call stack:
  • ebuild.sh, line 85: Called src_compile
  • environment, line 2036: Called mythtv-plugins_src_compile
  • environment, line 1863: Called die
  • The specific snippet of code:
emake
die "make failed to compile"
  • If you need support, post the output of 'emerge --info =media-plugins/mythgame-0.25_pre20120329',
  • the complete build log and the output of 'emerge -pqv =media-plugins/mythgame-0.25_pre20120329'.
  • This ebuild used the following eclasses from overlays:
  • /gentoo/overlay/mythtv/Gentoo/eclass/mythtv-plugins.eclass
  • /gentoo/overlay/mythtv/Gentoo/eclass/mythtv.eclass
  • This ebuild is from an overlay named 'mythtv': '/gentoo/overlay/mythtv/Gentoo/'
  • The complete build log is located at '/tmp/portage/media-plugins/mythgame-0.25_pre20120329/temp/build.log'.
  • The ebuild environment file is located at '/tmp/portage/media-plugins/mythgame-0.25_pre20120329/temp/environment'.
  • S: '/tmp/portage/media-plugins/mythgame-0.25_pre20120329/work/MythTV-mythtv-f73dbda/mythplugins'

Change History (3)

comment:1 Changed 8 years ago by Raymond Wagner

Keywords: Gentoo zlib removed
Resolution: Invalid
Status: newclosed

Duplicate of #10507.

comment:2 Changed 8 years ago by Raymond Wagner

Resolution: Invalid
Status: closednew

comment:3 Changed 8 years ago by Raymond Wagner

Resolution: Duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.