Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10545 closed Bug Report - General (fixed)

Unable to switch inputs in live tv if they are in the same input group.

Reported by: David Stanczak <dstanczak@…> Owned by: Jim Stichnoth
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Switching between inputs that are in the same input group while watching live tv no longer works.

The "Playback Menu->Source->Switch Input" no longer exists in live tv.

Using the guide to switch to a channel that is only on the other input exits the guide without changing the channel.

Typing the channel number in manually results in the following message. "MythTV is already using all available inputs for the channel you selected. If you want to switch an in-progress recording, selec..."

Attachments (2)

version_info.txt (717 bytes) - added by David Stanczak <dstanczak@…> 8 years ago.
mythtv version
change_input_logs.txt (1.5 KB) - added by David Stanczak <dstanczak@…> 8 years ago.
logs from my attempts to change inputs

Download all attachments as: .zip

Change History (14)

Changed 8 years ago by David Stanczak <dstanczak@…>

Attachment: version_info.txt added

mythtv version

Changed 8 years ago by David Stanczak <dstanczak@…>

Attachment: change_input_logs.txt added

logs from my attempts to change inputs

comment:1 Changed 8 years ago by Jim Stichnoth

Milestone: 0.25unknown
Status: newinfoneeded_new
Version: UnspecifiedMaster Head

The "Source->Switch Input" menu is not actually gone in Live TV, it is just suppressed when the system believes no additional inputs are available for Live TV.

Please run mythtv-setup, select Input Connections, select each connection in turn, and check the "Live TV Order" setting on the second page. If the value is 0, then that input is excluded from Live TV (see the help text).

comment:2 Changed 8 years ago by David Stanczak <dstanczak@…>

I played around with the "Live TV Order" and it effected which input was used for live tv, but I was still unable to switch between inputs in live tv.

Here are all the values I tried. I don't think it matters but I didn't run mythfilldatabase after changing these values.


S-video input = Input priority: 0, Schedule order: 1, Live TV Order: 1

Firwire input = Input priority: 0, Schedule order: 2, Live TV Order: 2 ==============================

S-video input = Input priority: 0, Schedule order: 1, Live TV Order: 1

Firwire input = Input priority: 0, Schedule order: 1, Live TV Order: 1 ==============================

S-video input = Input priority: 0, Schedule order: 1, Live TV Order: 2

Firwire input = Input priority: 0, Schedule order: 1, Live TV Order: 1

comment:3 Changed 8 years ago by David Stanczak <dstanczak@…>

I should probably have mentioned this earlier but removing the input group from these inputs allows me to switch between them in live tv.

comment:4 Changed 8 years ago by Jim Stichnoth

Milestone: unknown0.25
Owner: set to Jim Stichnoth
Status: infoneeded_newassigned

comment:5 Changed 8 years ago by Jim Stichnoth

Status: assignedaccepted

comment:6 Changed 8 years ago by Jim Stichnoth

Do your two inputs have different sources?

If that is true, then is_input_group_busy() decides that both inputs are effectively in use, and they are suppressed from the OSD menu.

comment:7 Changed 8 years ago by David Stanczak <dstanczak@…>

Whether the two inputs use the same source or different sources doesn't seem to make a difference.

comment:8 Changed 8 years ago by Jim Stichnoth

The other part of the logic in is_input_group_busy() tests whether the candidate input (i.e. the one not currently showing Live TV but in the same input group) is analog. This is defined according to the query:

select mplexid, atsc_minor_chan, serviceid from channel 
where (mplexid != 32767 or atsc_minor_chan != 0 or serviceid != 0) 
and sourceid=<SOURCEID>;

where <SOURCEID> is the appropriate result from:

select sourceid from videosource;

If the first query returns no results, then the source is determined to be analog and the input is determined to be busy.

Can you run this query and see if this is indeed the case here?

comment:9 Changed 8 years ago by David Stanczak <dstanczak@…>

Running the query on each sourceid returns an empty result set.

comment:10 Changed 8 years ago by Jim Stichnoth

Milestone: 0.250.26

Thanks for providing the data. It's fairly clear what the issue is, but that area of code is too sensitive to touch this close to the 0.25 release. I'm pushing the milestone to 0.26, but I would prefer to fix it in 0.25-fixes after the release.

comment:11 Changed 8 years ago by Jim Stichnoth

Milestone: 0.260.25
Resolution: Fixed
Status: acceptedclosed

Fixed in a970d72b8fb0fdaaffd52c571e039f27e7ed0ebf

Please re-open if the problem is still there.

comment:12 Changed 8 years ago by Mario Limonciello <Mario_Limonciello@…>

Resolution: Fixedfixed

In 47bed8ed5e6ee58876df6b04cda84a853b257f48/packaging:

  • Update to 0.25 gold release.
  • New upstream checkout (1f5962a)
  • >>Upstream changes since last upload (041ecad):
  • [1f5962a] RingBuffer?: Make a few more attempts to read when oldfile=true.
  • [cffed2b] Merge branch 'master' of github.com:MythTV/mythtv
  • [4f16846] Update the Danish translation of mythfrontend and all plugins.
  • [31fa9dd] Revert "Fix popup windows from disappearing in MythCenter?- wide when using the"
  • [d824ea2] Fix issues with 805453a6 and df8548e7.
  • [4b28a57] Remove the MythArchive? date/time formats from the Hong Kong Chinese locale file.
  • [df8548e] Add a null pointer check on 'screen'
  • [805453a] Don't trigger hide/show animations if the screens should still be visible because the foreground screen isn't fullscreen.
  • [d1b081e] Updated Czech MythFrontend translation
  • [e6c4aa0] Updated Polish MythFrontend and alll plugins translation from Warpme
  • [39695b2] Revert "Fixes #10490. Don't return from safe_read() early on stopreads if we haven't read any bytes, this looks like an eof to higher levels of code."
  • [28db6ca] Merge branch 'master' of github.com:MythTV/mythtv
  • [e6d3ecb] Updated French MythFrontend, MythMusic, MythNetvision? and MythNews? translation from the French Language Translation Team
  • [6473241] Update the Danish translation of mythfrontend.
  • [c52a7cf] Updated Czech MythFrontend and MythMusic translation
  • [8c6c8cd] Updated German MythFrontend and MythZoneMinder? translation from Florian Bittner
  • [aa2762f] Fix popup windows from disappearing in MythCenter?-wide when using the virtual keyboard.
  • [393295c] Fixes #10490. Don't return from safe_read() early on stopreads if we haven't read any bytes, this looks like an eof to higher levels of code.
  • [81e72c8] Clear the UI object stores when deleting MythThemeBase?, fixes themes using the wrong base window and fonts after displaying the locale/database prompts. This was already done implicitly when shutting down and explicitly when reloading themes but not in the third case, where we construct a temporary main window and MythMainWindow? is torn down instead of being re-initialised.
  • [a970d72] Fixes #10545. Populate the Switch Input menu with all available cards.
  • [d80e54b] Fix #10558
  • [14ca636] Bump binary version
  • [00bd9eb] Fix compilation following previous commit
  • [e84a9a8] Fix compilation following previous commit
  • [4c5b039] Initialise locale if it's not been done already by the time we call GetQLocale()
  • [9c73366] Translate dates/times in the DateFormat? settings
  • [a0ae652] Move Setup Wizard at the top of settings menu (part #2)
  • [02216ca] Fix video setup wizard if audio test wasn't stopped in the previous screen
  • [13652d7] Fix audio setup and add handling of extra cases.
  • [b36827e] Better handling of unmounted volumes. Refs #10450.
  • [83671d5] Revert "Better handling of unmounted volumes. Refs #10450"
  • [58e8506] Better handling of unmounted volumes. Refs #10450
  • [71a024d] Fix LoadFromOldRecorded? query in ProgList?.
  • [957917c] Replicate the spelling change I had done in 3740d7dda16b2a082f8d833f4459294202cb2687
  • [8df36ec] Translate missed string.
  • [82f9818] Improve audio setup
Note: See TracTickets for help on using tickets.