Opened 7 years ago

Closed 7 years ago

#10550 closed Bug Report - General (Works for me)

Can't re-enter LiveTV under some circumstances

Reported by: JYA Owned by: danielk
Priority: critical Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If you are entering LiveTV and the last channel you watched on LiveTV doesn't exist or can't be tuned to for whatever reason ; LiveTV will not start and you either go back to the main menu or mythfrontend will lock up.

When trying to enter LiveTV, "Please wait" message is displayed then "Error opening jump program file".

If you have selected to display the program guide upon entering LiveTV, everything locks up and mythfrontend must be killed to restart

Change History (8)

comment:1 Changed 7 years ago by beirdo

Milestone: 0.25unknown

comment:2 Changed 7 years ago by cocobrother@…

I have the same problem since Version 0.25 after a 2-4sec. blacksreen came "Error opening jump program file".

comment:3 Changed 7 years ago by hidden.minds@…

I have the same problem too. I have DVB-S2 capture cards in the mythtv-backend. On the frontends I am using Nvidias vdpau.

comment:4 Changed 7 years ago by danielk

jya, does this problem occur with XVideo playback?

I believe this may be limited to the more recently implemented video renderers.

comment:5 Changed 7 years ago by JYA

I don't use XVideo, only either OpenGL or VDPAU.

I thought the issue was more related to the initial tuning not working and would have nothing to do with the UI related stuff

comment:6 Changed 7 years ago by danielk

Status: newinfoneeded_new

jya, there was a bug with some renders where they didn't show the tuning UI and presumably didn't respond to the backend about how to proceed. However I'm not seeing this bug currently with VDPAU or XVideo playback (OpenGL playback isn't working here).

I'm not able to reproduce either scenario here so I'm going to need a "-v record,channel" log from the backend and a "-v playback,channel" log from the frontend.

Unplugging the antenna cable should allow you to reproduce on any channel at start up.

comment:7 Changed 7 years ago by beirdo

Priority: majorcritical

comment:8 Changed 7 years ago by danielk

Resolution: Works for me
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.