Opened 8 years ago

Closed 8 years ago

#10560 closed Bug Report - General (Duplicate)

Crash in video playback after just changing the theme

Reported by: JYA Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Changing the theme, and immediately going into the setup wizard crashes.

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x0000000100000200
0x000000012057d012 in gldCopyTexSubImage ()
(gdb) bt
#0  0x000000012057d012 in gldCopyTexSubImage ()
#1  0x000000012057d3a0 in gldCopyTexSubImage ()
#2  0x000000012056aa8d in gldUpdateDispatch ()
#3  0x000000012033fc8a in gleBeginPrimitiveTCLFunc ()
#4  0x00000001202cb169 in gleDrawArraysOrElements_ExecCore ()
#5  0x00000001202c0f0a in glDrawArrays_IMM_Exec ()
#6  0x000000010380c01d in MythRenderOpenGL1::DrawBitmapPriv (this=0x107d9fb10, 
    textures=0x7fff5fbfb014, texture_count=1, src=0x7fff5fbfb068, 
    dst=0x7fff5fbfb028, prog=1) at mythrender_opengl1.cpp:374
#7  0x00000001037e75d8 in MythRenderOpenGL::DrawBitmap (this=0x107d9fb10, 
    textures=0x7fff5fbfb014, texture_count=1, target=1, src=0x7fff5fbfb068, 
    dst=0x7fff5fbfb028, prog=1) at mythrender_opengl.cpp:709
#8  0x00000001010f0ce8 in OpenGLVideo::PrepareFrame (this=0x11b3aefe0, 
    topfieldfirst=false, scan=kScan_Interlaced, softwareDeinterlacing=true, 
    frame=1, stereo=kStereoscopicModeNone, draw_border=false)
    at openglvideo.cpp:1066
#9  0x0000000101105a22 in VideoOutputOpenGL::PrepareFrame (this=0x127821600, 
    buffer=0x1081ebe00, t=kScan_Interlaced, osd=0x1183c71e0)
    at videoout_opengl.cpp:576
#10 0x0000000100ef5820 in MythPlayer::AVSync (this=0x1083f6400, 
    buffer=0x1081ebe00, limit_delay=false) at mythplayer.cpp:1848
#11 0x0000000100f09c2d in MythPlayer::DisplayNormalFrame (this=0x1083f6400, 
    check_prebuffer=true) at mythplayer.cpp:2166
---Type <return> to continue, or q <return> to quit--- 
#12 0x0000000100ee7182 in MythPlayer::VideoLoop (this=0x1083f6400)
    at mythplayer.cpp:2335
#13 0x0000000100e6f81f in TV::PlaybackLoop (this=0x11fafafe0)
    at tv_play.cpp:1364
#14 0x0000000100eb034f in TV::StartTV (tvrec=0x126ee9340, flags=8)
    at tv_play.cpp:379
#15 0x000000010001ad47 in internal_play_media (mrl=@0x7fff5fbfd550, 
    plot=@0x7fff5fbfd560, title=@0x7fff5fbfd558, subtitle=@0x7fff5fbfd398, 
    director=@0x7fff5fbfd390, season=0, episode=0, inetref=@0x7fff5fbfd388, 
    lenMins=120, year=@0x7fff5fbfd380, id=@0x7fff5fbfd378, useBookmark=false)
    at main.cpp:1191
#16 0x00000001035c3eee in MythMainWindow::HandleMedia (this=0x107c415c0, 
    handler=@0x7fff5fbfd3a0, mrl=@0x7fff5fbfd550, plot=@0x7fff5fbfd560, 
    title=@0x7fff5fbfd558, subtitle=@0x7fff5fbfd398, director=@0x7fff5fbfd390, 
    season=0, episode=0, inetref=@0x7fff5fbfd388, lenMins=120, 
    year=@0x7fff5fbfd380, id=@0x7fff5fbfd378, useBookmarks=false)
    at mythmainwindow.cpp:1889
#17 0x0000000100386932 in VideoSetupWizard::playVideoTest (this=0x107bef780, 
    desc=@0x7fff5fbfd560, title=@0x7fff5fbfd558, file=@0x7fff5fbfd550)
    at setupwizard_video.cpp:216
#18 0x000000010038752a in VideoSetupWizard::testHDVideo (this=0x107bef780)
    at setupwizard_video.cpp:206
#19 0x00000001004971d0 in VideoSetupWizard::qt_static_metacall (
---Type <return> to continue, or q <return> to quit---
    _o=0x107bef780, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff5fbfd7a0)
    at moc_setupwizard_video.cpp:63
#20 0x00000001077eec01 in QMetaObject::activate ()
#21 0x00000001038119bf in MythUIButton::Clicked (this=0x11835f920)
    at moc_mythuibutton.cpp:111
#22 0x00000001036d6895 in MythUIButton::Push (this=0x11835f920, lock=false)
    at mythuibutton.cpp:183
#23 0x00000001036d6b13 in MythUIButton::keyPressEvent (this=0x11835f920, 
    e=0x7fff5fbfe158) at mythuibutton.cpp:144
#24 0x00000001003894be in VideoSetupWizard::keyPressEvent (this=0x107bef780, 
    event=0x7fff5fbfe158) at setupwizard_video.cpp:156
#25 0x00000001035c535c in MythMainWindow::eventFilter (this=0x107c415c0, 
    unnamed_arg=0x107c415c0, e=0x7fff5fbfe158) at mythmainwindow.cpp:1963
#26 0x00000001077d7251 in QCoreApplicationPrivate::sendThroughObjectEventFilters ()
#27 0x000000010699c278 in QApplicationPrivate::notify_helper ()
#28 0x000000010699c8fc in QApplication::notify ()
#29 0x00000001077d9602 in QCoreApplication::notifyInternal ()
#30 0x000000010699ba1a in qt_sendSpontaneousEvent ()
#31 0x0000000106a0e352 in QKeyMapper::sendKeyEvent ()
#32 0x0000000106a0f79e in QKeyMapperPrivate::translateKeyEvent ()
#33 0x0000000106957b6d in qt_dispatchKeyEvent ()
#34 0x000000010694a7a4 in -[QCocoaView keyDown:] ()
---Type <return> to continue, or q <return> to quit---
#35 0x00007fff88f61b44 in -[NSWindow sendEvent:] ()
#36 0x00000001069502cf in -[QCocoaWindow sendEvent:] ()
#37 0x00007fff88efa16d in -[NSApplication sendEvent:] ()
#38 0x0000000106953ad2 in -[QNSApplication sendEvent:] ()
#39 0x00007fff88e901f2 in -[NSApplication run] ()
#40 0x000000010695cce0 in QEventDispatcherMac::processEvents ()
#41 0x00000001077d6b78 in QEventLoop::exec ()
#42 0x00000001077d9d53 in QCoreApplication::exec ()
#43 0x00000001000285d7 in main (argc=3, argv=0x7fff5fbffa70) at main.cpp:1762

Change History (1)

comment:1 Changed 8 years ago by JYA

Resolution: Duplicate
Status: newclosed

Actually convince that this is a duplicate of #10561

Note: See TracTickets for help on using tickets.