Opened 8 years ago

Closed 7 years ago

#10585 closed Bug Report - General (Works for me)

MythGallery does not scale images properly to fit screen

Reported by: Michael Hughes <marynya@…> Owned by: beirdo
Priority: minor Milestone: unknown
Component: Plugin - MythGallery Version: 0.25
Severity: medium Keywords: mythgallery image scaling
Cc: Ticket locked: no

Description

MythGallery scales images to the width of the screen while ignoring the height. On a wide-screen monitor, camera images, which have 5:4 aspect, will have about 1/3 of the image off the bottom of the screen if they are "landscape" mode and 2/3 if they are "portrait" mode. Disabling EXIF support does not affect this. This function worked properly in 0.25-beta and I think it worked in 0.25-rc although I did not have that one for very long and may not have noticed. At any rate, this seems to have developed close to the end of the release process for 0.25.

Attachments (1)

MythFrontendVersion.txt (729 bytes) - added by Michael Hughes <marynya@…> 8 years ago.
mythfrontend --version output

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: 0.25.1unknown
Priority: majorminor
Severity: highmedium

Please read the TicketHowTo before creating tickets.

comment:2 Changed 8 years ago by beirdo

Please indicate the version you are running (mythfrontend --version).

Changed 8 years ago by Michael Hughes <marynya@…>

Attachment: MythFrontendVersion.txt added

mythfrontend --version output

comment:3 in reply to:  2 Changed 8 years ago by Michael Hughes <marynya@…>

Replying to beirdo:

Please indicate the version you are running (mythfrontend --version).

--version attached

Source from download page tarballs, not git repo.

comment:4 Changed 8 years ago by beirdo

So you downloaded 0.25pre? That makes no sense. Hmm, maybe the release script needs a minor tweak.

comment:5 in reply to:  4 Changed 8 years ago by Michael Hughes <marynya@…>

Replying to beirdo:

So you downloaded 0.25pre? That makes no sense. Hmm, maybe the release script needs a minor tweak.

I cloned the repo and built "checkout v0.25" which produced the same result. "--version" says "v0.25" for this one.

Discussion in the dev list suggests that the version file is wrong for non-git builds.

comment:6 Changed 7 years ago by beirdo

Resolution: Works for me
Status: newclosed

I can not reproduce this. My suspicion is that you had the zoom mode set, and this overrides the normal aspect ratio. All of my gallery pictures work fine for me, whether 4:3, 5:4, 16:9... all on a 16:9 display.

Note: See TracTickets for help on using tickets.