Opened 8 years ago

Closed 8 years ago

#10606 closed Bug Report - General (Fixed)

Cutlist editor and keyframe selection

Reported by: J.Pilk@… Owned by: Jim Stichnoth
Priority: minor Milestone: 0.26
Component: MythTV - Video Decoding Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using mythtv-0.25-285.el6.i686.rpm from ATrpms

Editing dvb-t2 HD recording. Stepping by keyframes consistently gives a degraded picture. Stepping back one frame, or stepping forward around eight frames, produces a crisp picture, and further one-frame steps in either direction remain crisp. Larger steps yield variable quality displays, probably depending on how far they are from the preceding keyframe. Seektable by mythcommflag --rebuild --file.

Seen on a laptop that can play this content smoothly at around 0.6 timestretch.

Video playback profile Normal. Frontend startup log extract:

2012-04-15 11:10:58.729330 I Trying the OpenGL painter 2012-04-15 11:10:58.804260 W OpenGL: Could not determine whether Sync to VBlank is enabled. 2012-04-15 11:10:58.874417 I OpenGL1: Fragment program support available 2012-04-15 11:10:58.874531 I OpenGL: OpenGL vendor : Tungsten Graphics, Inc 2012-04-15 11:10:58.874550 I OpenGL: OpenGL renderer: Mesa DRI Intel(R) 945GM 2012-04-15 11:10:58.874584 I OpenGL: OpenGL version : 1.4 Mesa 7.11 2012-04-15 11:10:58.874607 I OpenGL: Max texture size: 2048 x 2048 2012-04-15 11:10:58.874626 I OpenGL: Max texture units: 8 2012-04-15 11:10:58.874640 I OpenGL: Direct rendering: Yes 2012-04-15 11:10:58.874662 I OpenGL: PixelBufferObject? support available 2012-04-15 11:10:58.874673 I OpenGL: Initialised MythRenderOpenGL

Mediainfo video output:

General ID : 16517 (0x4085) Complete name : /home/john/Mythrecs/1050_20120414155800.mpg Format : MPEG-TS File size : 2.92 GiB Duration : 43mn 10s Overall bit rate mode : Variable Overall bit rate : 9 669 Kbps

Video ID : 6601 (0x19C9) Menu ID : 1 (0x1) Format : AVC Format/Info? : Advanced Video Codec Format profile : High@L4.0 Format settings, CABAC : Yes Format settings, ReFrames? : 4 frames Format settings, GOP : M=8, N=24 Codec ID : 27 Duration : 43mn 9s Width : 1 440 pixels Height : 1 080 pixels Display aspect ratio : 16:9 Frame rate : 25.000 fps Color space : YUV Chroma subsampling : 4:2:0 Bit depth : 8 bits Scan type : MBAFF Scan order : Top Field First Color primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177 Transfer characteristics : BT.709-5, BT.1361 Matrix coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Change History (5)

comment:1 Changed 8 years ago by Jim Stichnoth

Status: newinfoneeded_new

Could you make a 50-100MB sample available somewhere for download?

I sometimes see similar behavior in some HD-PVR h.264 recordings. If I keep jumping forward, eventually the display "settles" and there are no more problems for the duration of the editing session.

The Master branch is soon going to see a new ffmpeg sync, so it would be good to try to reproduce the problem in Master before and after the ffmpeg sync.

comment:2 Changed 8 years ago by J.Pilk@…

http://www.mediafire.com/?xpcu0gs5rptwwpg

It's 47.6 Mib - the last time I tried with over 50 MiB I had problems. Recording made because I wanted to see a picture with lots of action.

I tried to make a copy of the 0.25 HD test video editable by copying it over a short recording and doing cutlist, seektable, filesize resets, but the editor didn't work with either of the seektables. Maybe it didn't like .mkv pretending to be .mpg.

I've seen 'memory' effects too; initially playback will quit if I leave the editor from somewhere late in the recording. but later it works as expected

comment:3 Changed 8 years ago by Jim Stichnoth

Owner: set to Jim Stichnoth
Status: infoneeded_newassigned

Thanks for the sample, I can see the problem in Master. I will try digging into it after the ffmpeg resync.

comment:4 Changed 8 years ago by J.Pilk@…

Good: thanks.

I noticed that mediainfo says this (although HD) is an MPEG-TS file, and I wondered if mythtranscode --mpeg2 --buildindex might work with it. In fact it finds keyframes at the same byte offsets as mythcommflag --rebuild but the framecounts, although starting similarly, get out of step. Since mediainfo says the duration is just under 40s@25fps it looks as if mythcommflag's count of 970 is better than mythtrancode's count of 1509. The editor gets its framecount display from whichever tool was used last.

Also applies for info to #10584

comment:5 Changed 8 years ago by Jim Stichnoth

Component: MythTV - GeneralMythTV - Video Decoding
Milestone: unknown0.26
Resolution: Fixed
Status: assignedclosed

After the latest ffmpeg resync in Master, this appears to be fixed. All manner of seeks in the cutlist editor give a clean, crisp image, unlike when the ticket was first opened.

Note: See TracTickets for help on using tickets.