Opened 9 years ago

Closed 9 years ago

#10620 closed Bug Report - Hang/Deadlock (Duplicate)

IPTV recorder throws mythbackend into endless loop/unresponsive state

Reported by: chemobejk@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: 0.25
Severity: medium Keywords: IPTV
Cc: Ticket locked: no

Description

I've updated from mythtv 0.24.2 to 0.25 on Fedora 16 on a box that has a DVB-C card and multicast IPTV (udp://224.... variety) connectivity. With 0.24 IPTV had serious problems with recording multiple recordings at the same time, so I was eager to test the rewritten IPTV recorder code.

Tests:

a) record single DVB-C stream: works OK

b) record multiple DVB-C streams: works OK

c) record single IPTV stream: recording starts and is OK, but recording is never stopped, i.e. mythbackend doesn't go back to idle

  • the next scheduled IPTV recording doesn't start
  • mythbackend can only be stopped with kill -9: "systemctl stop mythbackend.service" tries for a long time and then gives up and uses kill -9.

d) record multiple IPTV streams: first two recordings are started, then mythbackend seems to be in some endless loop, reacting very slowly

  • frontend/mythfilldatabase/mythweb either have extremely slow reaction or timeout
  • a third scheduled IPTV recording is NOT started
  • the two recordings go on forever
  • mythbackend can only be stopped with kill -9

The attached log are the mythbackend messages filtered out of syslog from my test:

[08:46] start first scheduled DVB-C recording [08:59] start second scheduled DVB-C recording [09:34] end second DVB-C recording [09:39] end first DVB-C recording [09:58] start first scheduled IPTV recording [10:34] stop first scheduled IPTV recording (NOTE: mythtvbackend keeps on writing data to the file!!!) [10:54] -> this is where the next scheduled IPTV recording should have started, but nothing happens [10:56] "systemctl stop mythbackend.service" -> two more messages until it gets killed with -9

Attachments (1)

dummy.log (40.1 KB) - added by chemobejk@… 9 years ago.
mythbackend messages extracted from syslog

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by chemobejk@…

Attachment: dummy.log added

mythbackend messages extracted from syslog

comment:1 Changed 9 years ago by chemobejk@…

Just to be sure that this isn't update or multiple-IPTV network recorder related I now

  • deleted all old 4 FreeBOX network recorder entries
  • created ONE new network recorder
  • started an IPTV recording

Still the same problem.

comment:2 Changed 9 years ago by chemobejk@…

FYI: just compiled 0.25/fixes @ 1a671d0b252d2b33bd1e96258e65a15d52a5fc7d: problem still exists

comment:3 Changed 9 years ago by sphery

Seems to be a dup of #9670 (see, specifically comment:31:ticket:9670).

comment:4 Changed 9 years ago by chemobejk@…

I'm certain this is a different problem. As far as I can tell from mplayer (also uses live555) and that IPTV recordings have subtitles, my IPTV provider sends TS not PS.

I applied the patch after comment:35:ticket:9670 and that didn't fix my problem.

FYI: I have live555-0-0.32.2011.09.02.fc16.i686 installed on my box.

comment:5 Changed 9 years ago by sphery

and a dup of #10493

comment:6 Changed 9 years ago by chemobejk@…

Agreed. Can an admin please close this as dup of #10493?

comment:7 Changed 9 years ago by danielk

Resolution: Duplicate
Status: newclosed

Duplicate of #10483.

Note: See TracTickets for help on using tickets.