Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 10 months ago

Last modified 10 months ago

#10651 closed Bug Report - General (Fixed)

JS and HTML errors in backend web interface

Reported by: jan@… Owned by: cpinkham
Priority: minor Milestone: 0.27
Component: MythTV - General Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Tue Apr 24 2012 12:02:19
Fehler: $.ui.multiselect is undefined
Quelldatei: http://htpc.wg.de:6544/js/ui-multiselect-en.js
Zeile: 7

----------

Tue Apr 24 2012 12:02:22
Fehler: Fatal error: Theme at /js/galleria/themes/classic/galleria.classic.min.js could not load, check theme path.
Quelldatei: http://htpc.wg.de:6544/
Zeile: 77

----------

Tue Apr 24 2012 12:02:25
Fehler: Fatal error: No theme found.
Quelldatei: http://htpc.wg.de:6544/
Zeile: 77

The first JS error is probably from loading ui-multiselect-en.js before ui-multiselect.js.

Beside that there is broken HTML in the "Last 10 Recordings" section. It renders like this:

====================================================
Letzte 10 Aufnahmen

Recorded Montag, April 23 at 21:15." src="/Content/GetPreviewImage??ChanId?=29450&Height=300&StartTime?=2012-04-23T19:15:00Z"/>Recorded Samstag, April 14 at 3:05." src="/Content/GetPreviewImage??ChanId?=12110&Height=300&StartTime?=2012-04-14T01:05:00Z"/>

Aktuelle Tuner Aktivitäten

=======================================================

The latter seems to have been a one-time issue though. I cannot reproduce anymore after reloading the page.

Attachments (0)

Change History (3)

comment:1 Changed 19 months ago by Jonatan Lindblad <jlindblad@…>

In bdbf7bfe8f568ec38541d4324387d762677f045f/mythtv:

HTML Setup: Fix loading of ui-multiselect-en.js

Fixes #10910. Refs #10651.

comment:2 Changed 10 months ago by cpinkham

  • Milestone changed from unknown to 0.27
  • Resolution set to Fixed
  • Status changed from new to closed

The default "Last 10" page was disabled in preference of the original status screen, so this should be a non-issue now.

comment:3 Changed 10 months ago by cpinkham

  • Owner set to cpinkham

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.