Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#10665 closed Bug Report - General (Unverified)

unable to connect to mythtv from other PCs

Reported by: fabio.marras@… Owned by: Raymond Wagner
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since I upgraded to version 0.25 I have the same problem reported in the ticket http://code.mythtv.org/trac/ticket/10654. Before the upgrade, the mythmote Android could connect to my MythTV. After the update, the mythmode can no longer connect.

Change History (10)

comment:1 Changed 8 years ago by Raymond Wagner

Milestone: 0.25.1unknown
Resolution: Invalid
Status: newclosed

Just as invalid as the previous ticket. If you specify what address MythTV's servers are to listen on, it will listen on that and only that address. Leave it blank, or set it to the address you want to connect to.

comment:2 Changed 8 years ago by Fabio <fabio.marras@…>

OK, but let me some things:

  • how do you explain that with the release 0.24 and the same configuration, mythtv was working well
  • don't you think that you should update the contextual help of the "ip address" field: it is not clear at all that I can leave it blank
  • I'm an user, not a developer. Is it allowed to have some doubt or problem using mythtv, or mythtv is for hackers only?

However, I have the impression that you did not understand my problem. The Mythtv client has no problem to connect to mythtv backend. I have problem with external clients, mythmote precisly, that try to connect to the mythtv-frontend on the port 6546.

Regards,

Fabio

comment:3 Changed 8 years ago by Raymond Wagner

I understand your problem. You are running a single combined frontend and master backend. With no remote frontends, you left the default IP configuration of 127.0.0.1. Since that value is set, the various servers in the frontend obediently follow it, and only listen on 127.0.0.1, meaning MyMote? cannot connect externally.

If you want to access your control socket from the network, set an accessible IP in mythtv-setup, or make that value blank so the frontend auto-selects appropriate addresses to listen on (which would of course break the backend which requires that setting). If for whatever reason you want to keep the backend listening only on 127.0.0.1, but still want your frontend to listen on a network accessible address, you need to run them using different configuration profiles, by manually specifying a profile to use with the "LocalHostName?" option in your ~/.mythtv/mysql.txt.

If the above is not an accurate assessment, feel free to re-open this ticket and provide logs from startup of your frontend.

comment:4 Changed 8 years ago by Fabio <fabio.marras@…>

Yes, I run a single combined frontend and master backend. I tryed to follow your instructions, but without success. I tested that my IP is accessible through mythweb: I manage to connect to http://192.168.1.132/mythweb from external clinet without problems. Wich log do I have to provide you? mythfrontend.log or mythbackend.log?

comment:5 Changed 7 years ago by fabio.marras@…

Resolution: Invalid
Status: closednew

I tried both suggestions you gave me, but without success. I continue to not to be able to access to my mythtv through MyMote? :-(

comment:6 Changed 7 years ago by Raymond Wagner

Status: newinfoneeded_new

I need to see frontend logs from startup. Specifically, this bit here...

2012-05-27 11:12:29.067391 I  Listening on TCP 127.0.0.1:6547
2012-05-27 11:12:29.081535 I  Listening on TCP 10.254.1.31:6547
2012-05-27 11:12:29.081849 I  Listening on TCP [0:0:0:0:0:0:0:1]:6547
2012-05-27 11:12:29.081909 I  Listening on TCP [2001:470:xxxx::x]:6547

comment:7 Changed 7 years ago by beirdo

Owner: set to Raymond Wagner

comment:8 Changed 7 years ago by Raymond Wagner

Resolution: Unverified
Status: infoneeded_newclosed

Six weeks with no response to show frontend is actually listening on accessible address. Closing under the assumption error is a misconfiguration as described.

comment:9 Changed 7 years ago by fabbio.marras@…

You are right! I'm very sorry, but with one wife and two sons it's not so easy to send a log :-( Meanwhile I update Mythtv, and my problem get bigger. I am running a single combined frontend and master backend and the frontend can't see the master backend. This are the pastbin code of frontend e backend log:

http://pastebin.com/bsWaTW1N http://pastebin.com/w4YjsjYN http://pastebin.com/Bs235ZHx

comment:10 Changed 7 years ago by Raymond Wagner

I believe this is a separate issue, so I have opened a new ticket for it. See #11030.

Note: See TracTickets for help on using tickets.