Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 23 months ago

#10678 closed Bug Report - General (Fixed)

displaying subtitles also shows random black text in middle of screen

Reported by: Jason Lewis <jason@…> Owned by: stichnot
Priority: minor Milestone: 0.25.1
Component: MythTV - Captions Version: 0.25-fixes
Severity: medium Keywords: subtitles black text
Cc: Ticket locked: no

Description

If you are watching a recording and turn subtitles on, you get occasional random black text in the middle of the screen. it appears sometimes when the subtitles refresh, then dissapears again when the next subtitle is displayed.

Playing a DVB-T recording. using .25- fixes.

Screenshots attached.

MythTV Version : v0.25-59-gae7ac79
MythTV Branch : 25fixes
Network Protocol : 72
Library API : 0.25.20120408-1
QT Version : 4.7.4
Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

Attachments (3)

Screen Shot 2012-05-01 at 9.24.44 PM.png (306.1 KB) - added by jason@… 2 years ago.
black text in middle of screen
Screen Shot 2012-05-01 at 9.24.44 PM.2.png (306.1 KB) - added by jason@… 2 years ago.
black text in middle of screen
Screen Shot 2012-05-01 at 9.30.13 PM.png (291.1 KB) - added by jason@… 2 years ago.
black text in middle of screen

Download all attachments as: .zip

Change History (11)

Changed 2 years ago by jason@…

black text in middle of screen

Changed 2 years ago by jason@…

black text in middle of screen

Changed 2 years ago by jason@…

black text in middle of screen

comment:1 Changed 2 years ago by stichnot

  • Component changed from MythTV - General to MythTV - Captions
  • Status changed from new to infoneeded_new

Could you upload a sample somewhere (around 50 MB if possible) that illustrates the problem? I don't have access to teletext recordings, and the handful of samples I have don't show the problem.

comment:2 Changed 2 years ago by Jason Lewis <jasonblewis@…>

I cut out a bit of a video that shows the error several times.

Its about 51meg and still uploading to dropbox so give it a while before trying to download it

http://dl.dropbox.com/u/1774741/subtitles-error.mpg

comment:3 Changed 2 years ago by stichnot

  • Owner set to stichnot

Thanks for the sample. I can reproduce the problem.

comment:4 Changed 2 years ago by stichnot

  • Status changed from infoneeded_new to assigned

comment:5 Changed 23 months ago by stichnot

  • Milestone changed from unknown to 0.26
  • Status changed from assigned to accepted

I have a fix that I'll commit to 0.25-fixes, but I'm setting the milestone to 0.26 since we will probably be cutting the 0.25.1 release before the fix gets enough testing in Master.

comment:6 Changed 23 months ago by Jim Stichnoth <jstichnoth@…>

In 419fc84c5c8d25dd17e5a0fac7b6860a5f82a602/mythtv:

Subtitles: Only display teletext captions inside the "box" area.

The spec says that characters outside the "Start Box" / "End Box"
region should not be displayed. Refs #10678.

comment:7 Changed 23 months ago by Jim Stichnoth <jstichnoth@…>

In e4349138af776a7d72dc39660ab648210c0baa1f/mythtv:

Subtitles: Only display teletext captions inside the "box" area.

The spec says that characters outside the "Start Box" / "End Box"
region should not be displayed. Refs #10678.
(cherry picked from commit 419fc84c5c8d25dd17e5a0fac7b6860a5f82a602)

comment:8 Changed 23 months ago by stichnot

  • Milestone changed from 0.26 to 0.25.1
  • Resolution set to Fixed
  • Status changed from accepted to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.