Opened 14 years ago

Closed 14 years ago

#1068 closed task (wontfix)

V4L API version 1 going away July 2006

Reported by: gnome42@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I just noticed this in linux-2.6.15-rc7/Documentation/feature-removal-schedule.txt

What: Video4Linux API 1 ioctls and video_decoder.h from Video devices.

When: July 2006 ...

My bttv card still uses V4L by default in myth. Maybe we should be switching to V4L2?

PS. I have been using V4L2 for years on my bttv card. I will attach a patch that I have been using for a while. I don't know if it works for all cards etc.

Regards,

Shane

Attachments (1)

NuppelVideoRecorder.v4l2.only.diff (1.7 KB) - added by gnome42@… 14 years ago.
use V4L2 example patch

Download all attachments as: .zip

Change History (2)

Changed 14 years ago by gnome42@…

use V4L2 example patch

comment:1 Changed 14 years ago by Isaac Richards

Resolution: wontfix
Status: newclosed

Not until they actually remove it.

Note: See TracTickets for help on using tickets.