Opened 14 years ago

Closed 14 years ago

#1072 closed patch (fixed)

MythGallery segfaults if image directory is empty

Reported by: otto@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythgallery Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With SVN 8639, MythGallery segfaults if image directory is empty. Another user confirmed this with SVN 8529.

Attachments (2)

gdb.txt (10.1 KB) - added by otto@… 14 years ago.
segfault backtrace
patch.diff (1.1 KB) - added by Aaron McCarthy <mccarthy.aaron@…> 14 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

A backtrace is required when reporting a crash.

Changed 14 years ago by otto@…

Attachment: gdb.txt added

segfault backtrace

comment:2 Changed 14 years ago by otto@…

Component: mythtvmythgallery
Resolution: invalid
Status: closedreopened

Here is the backtrace. Please let me know if it's not valid since this is the first backtrace for me.

Changed 14 years ago by Aaron McCarthy <mccarthy.aaron@…>

Attachment: patch.diff added

comment:3 Changed 14 years ago by Aaron McCarthy <mccarthy.aaron@…>

Type: defectpatch

I've attached a patch that should fix the problem.

comment:4 Changed 14 years ago by otto@…

Yes, patch works and frontend doesn't crash anymore.

comment:5 Changed 14 years ago by cpinkham

Resolution: fixed
Status: reopenedclosed

(In [8691]) Fix segfault in MythGallery. Applies patch from and closes #1072.

Note: See TracTickets for help on using tickets.