Opened 8 years ago

Closed 8 years ago

#10722 closed Bug Report - General (Won't Fix)

mythshutdown -l isn't recognised

Reported by: John Veness <John.Veness.mythtv@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Mythwelcome & Mythshutdown Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In 0.25-fixes, the "-l" command-line option to mythshutdown doesn't work (it worked in 0.24-fixes). "--lock" still works in 0.25-fixes.

Looking in mythtv/programs/mythshutdown/commandlineparser.cpp, "-l" is still listed as an alias for "--lock", so I don't think this was a deliberate change.

I'm wondering if the problem is in mythtv/libs/libmythbase/mythcommandlineparser.cpp because of the section "add(QStringList( QStringList() << "-l" << "--logfile" )" but I haven't investigated further or compared to the 0.24-fixes version of that file.

Quite a few scripts that users will have made, and web pages, refer to "mythshutdown -l".

Sorry, I'm not in front of my machine to I don't have output of --version.

Change History (1)

comment:1 Changed 8 years ago by beirdo

Resolution: Won't Fix
Status: newclosed

-l is now used for logfile (which is deprecated). Use --lock.

Note: See TracTickets for help on using tickets.