Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#10733 closed Patch - Bug Fix (Won't Fix)

[PATCH] ffmpeg: Allow building with libx264 >= 0.85

Reported by: Lawrence Rust <lvr@…> Owned by: beirdo
Priority: minor Milestone: unknown
Component: MythTV - configure script Version: Unspecified
Severity: medium Keywords: ffmpeg libx264
Cc: Ticket locked: yes

Description

Commit 9cb02dee (Make it compile at least the ffmpeg part) added a test in configure for libx264 headers >= 118 so that FFmpeg/libavcodec/libx264.c compiled. Unfortunately, only the most recent distributions of Ubuntu (>=12.04) ship with this version meaning that h264 compression can't be built in earlier standard Ubuntu versions such as 10.04 LTS which is still supported.

The dependency on libx264 headers in libx264.c can be conditionally compiled meaning that older libx264 versions can be supported.

Attachments (1)

0001-ffmpeg-Allow-building-with-libx264-0.85.patch (3.1 KB) - added by Lawrence Rust <lvr@…> 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Lawrence Rust <lvr@…>

comment:1 Changed 7 years ago by beirdo

Resolution: Won't Fix
Status: newclosed

This is unnecessary. We are going to use what is in ffmpeg with minimal changes. We are trying to reduce/eliminate our deltas from ffmpeg, not add more.

comment:2 Changed 7 years ago by Lawrence Rust <lvr@…>

Don't expect a lot of Ubuntu users testing git master then

comment:3 Changed 7 years ago by beirdo

Ticket locked: set

They can do exactly what I've done: change sources to precise, apt-get update, apt-get install libx264-dev, then change the sources back and apt-get update.

I'm sorry, but I'm not going to mess with our code to unnecessarily support outdated packages when the updated ones are readily available.

Oh, and I'm an ubuntu user (10.04.2 on my mythboxes, one of which is our 64-bit buildbot slave, and is compiling with x264 just fine).

Note: See TracTickets for help on using tickets.