Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10739 closed Bug Report - Hang/Deadlock (Invalid)

mythbackend periodic deadlock

Reported by: andrew@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25-fixes
Severity: medium Keywords: deadlock mythbackend
Cc: Ticket locked: no

Description

My backend is experiencing periodic deadlocks after applying http://code.mythtv.org/trac/attachment/ticket/10541/10541-v2.patch to mythtv-0.25_rc20120510.ebuild

MYTHTV_VERSION="v0.25-85-g77d0afc"
MYTHTV_BRANCH="fixes/0.25", MYTHTV_REV="77d0afc9b155161c402abc328edae86b0c97a797"
MYTHTV_SREV="77d0afc"

I would add to #10541 but there is a comment there that the deadlock is fixed buy the second patch (which I am using), so this is probably a completely unrelated problem. If I take this patch out of my e-build I end up with periodic crashes of the backend (1-2 times a week) instead, so they may be related in some way.

I have an always on backend and slave frontends which connect to it as required. Approx 1 to 2 times a week a frontend will fail to connect to the backend process, at which time I have to ssh on to the backend and killall -9 before re-starting the backend (a standard kill doesn't seem to be enough).

Attachments (1)

gdb.txt (72.2 KB) - added by andrew@… 8 years ago.
backtrace of the deadlock

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by andrew@…

Attachment: gdb.txt added

backtrace of the deadlock

comment:1 Changed 8 years ago by stuartm

Resolution: Invalid
Status: newclosed

If you read to the end of that ticket you'll see that a fix for the crash has been committed to master (it will be backported soon) and that the deadlock you're experiencing was caused by the patch you've applied.

comment:3 Changed 7 years ago by Andrew Fowler <andrew@…>

As suggested I applied the final commit patch instead. After a 2 week holiday (all shows recorded) followed by a reboot, the back-end has now been up and stable for 8 days - no deadlocks :-).

Looks like this has fixed my issues, with no obvious nasty side-effects. Suggest that it be considered ready for the 0.25/fixes branch (assuming it hasn't already been back-ported!)

Note: See TracTickets for help on using tickets.