Opened 8 years ago

Closed 8 years ago

#10741 closed Bug Report - Hang/Deadlock (Upstream Bug)

Changing channels in LiveTV with HDPVR periodically fails on remote frontend

Reported by: mitch.capper@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When in liveTV on a remote frontend tuned with the HDPVR and changing to a new channel on the HDPVR the change to the new channel plays for 2 seconds or so then pauses then freezes.

Problem is not reproducible with other inputs including dual tuner hd home run or hd5500. Problem only occurs on remote frontends. Problem does not occur with -prerecorded programs. Problem does not happen with initially entering live-tv only when changing channels when the HDPVR is already tuned to a specific channel and is changed to another. Problem occurs if the guide is on screen or when changing just using the OSD with channel up and down. Frontend and backend should be are within 1 second of each other for time. Currently running on 568e161f39a33cde70ba1a74081ab46d28006a2c (may 4th) Has been happening for at least many months.

Tried with signal_timeout set to 1000 and 4000 and channel_timeout at 3000 and 12000 on the hdpvr card.

I attached the log files running with -v all and without -v at all. Both showing the same situation. For the non verbose a timeline is: 16:36:28 - enter live TV and enters without problem on channel 280 16:36:51 - hit guide button 16:37:18 - changed to channel 278 16:37:30 - playes a few seconds of video and freezes 16:37:43 - plays another second of video completed frozen 16:38:16 - kicked out of live TV video buffering error

On the frontend running local to the backend it shows a similar behavior with a pause when changing channels after playing a 2-3 seconds of video but then it continues normally.

For the verbose logs the channel change is at 16:21:36 channel was changed to a new channel(280)

Change History (3)

comment:1 Changed 8 years ago by mitch.capper@…

Logs are 2M zipped so they are hosted at http://mitchcapper.com/myth-logs.zip

comment:2 Changed 8 years ago by mitch.capper@…

After trying several different things upgrading the HDPVR firmware from the recommended 1.5.7, from June 17, 2010 to Mar 7 2012 and the problem is gone. This was the only change made to resolve the issue. As far as I am concerned this ticket can be closed.

comment:3 Changed 8 years ago by Kenni Lund [kenni a kelu dot dk]

Priority: majorminor
Resolution: Upstream Bug
Status: newclosed

Thank you for reporting back.

Note: See TracTickets for help on using tickets.