Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#10777 closed Bug Report - General (Invalid)

Audio, but no video with 0.25

Reported by: mythtv@… Owned by: JYA
Priority: major Milestone: unknown
Component: Ports - OSX Version: 0.25-fixes
Severity: medium Keywords: osx video playback
Cc: Ticket locked: no

Description

When I try to play a recording or the videos available in Setup Wizard, I hear the audio. The screen displays the numeral 1 with "Playback starting..." below it. I have tried all the video playback profiles available with the same result for every one.

Change History (5)

comment:1 Changed 7 years ago by JYA

Resolution: Invalid
Status: newclosed

Set Setup -> Appearance -> Auto

comment:2 Changed 7 years ago by sphery

specifically the setting:

Paint engine
This selects what MythTV uses to draw. Choosing 'Auto' is recommended,
unless running on systems with broken OpenGL implementations (broken
hardware or drivers or windowing systems) where only Qt works.

comment:3 Changed 7 years ago by JYA

Core issue is that the default settings are just plain wrong and break it on mac. Default is Qt, shouldn't be

comment:4 Changed 7 years ago by Craig Treleaven <ctreleaven@…>

In limited testing of 25-fixes*, I've found that Setup>Appearance OpenGL enables video playback (MPEG2 recordings from HDHomerun AND DVD rips).

BUT

If OpenGL is selected, a bunch of other screens are broken. Eg: -Setup>Media settings>Image Settings => screen doesn't paint; can 'exit' back to previous screen via Esc. -MythBrowser? produces a blank screen -MythNews? produces a blank screen.

I believe this also affects (several? all?) screens in MythTV-Setup but I didn't have a chance to switch the OpenGL/Qt setting and try again.

Please let me know what kind of logs would be useful and I'll produce them tomorrow.

*Built via the MacPorts? build process I'm working on. Hopefully I haven't shot myself in the foot but my experience seems to mirror others using the osx-packager built apps.

comment:5 Changed 6 years ago by rob@…

I just downloaded the latest 0.25 builds from the source forge project. It defaulted to Qt drawing and I had no video, but audio worked fine.

Once I changed to "Auto", all was well. So almost the oposite of what you found.

Note: See TracTickets for help on using tickets.