Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 23 months ago

Closed 22 months ago

Last modified 22 months ago

#10821 closed Bug Report - General (fixed)

Mythweather unable to retrieve weather data from NDFD

Reported by: abauer <knnniggett@…> Owned by: beirdo
Priority: minor Milestone: 0.25.2
Component: Plugin - MythWeather Version: 0.25.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Problem:
Mythweather is unable to display weather data from any screen that uses NDFD (e.g. 18 hour forecast, six day forecast, etc). Other screens that use NOAA and wunderground appear to work fine.

Relevant System Info:
Mythbuntu 12.04 x86_64
Mythtv 0.25.1 + latest fixes

Steps to reproduce:
Add 18 hour forecast & Six Day Forecast as an active screen, using a location of “KBLV”, then observe that these screens do not populate when they are viewed. In addition to my htpc, I have been able to reproduce this issue in a virtual machine with a fresh install of Mythbuntu 0.25.1.

Relevant mythfrontend log entries:

Jun  9 10:21:03 ubuntu-pvr mythfrontend[1791]: N CoreContext mythmainwindow.cpp:2652 (ExitStandby) Leaving standby mode
Jun  9 10:21:10 ubuntu-pvr mythfrontend[1791]: I CoreContext mythdbcon.cpp:395 (PurgeIdleConnections) New DB connection, total: 2
Jun  9 10:21:38 ubuntu-pvr mythfrontend[1791]: E CoreContext weatherScreen.cpp:122 (prepareScreen) Widget not found updatetime
Jun  9 10:21:38  mythfrontend[1791]: last message repeated 2 times
Jun  9 10:21:38 ubuntu-pvr mythfrontend[1791]: I CoreContext weatherSource.cpp:424 (startUpdate) Starting update of NWS-XML
Jun  9 10:21:38 ubuntu-pvr mythfrontend[1791]: I CoreContext weatherSource.cpp:424 (startUpdate) Starting update of NDFD-18_Hour
Jun  9 10:21:38 ubuntu-pvr mythfrontend[1791]: I CoreContext weatherSource.cpp:424 (startUpdate) Starting update of NDFD-6_day
Jun  9 10:21:38 ubuntu-pvr mythfrontend[1791]: I CoreContext weatherSource.cpp:424 (startUpdate) Starting update of wunderground-animaps
Jun  9 10:21:38 ubuntu-pvr mythfrontend[1791]: E CoreContext weatherScreen.cpp:122 (prepareScreen) Widget not found updatetime
Jun  9 10:21:39 ubuntu-pvr mythfrontend[1791]: E CoreContext weatherSource.cpp:518 (processExit) script exit status 255
Jun  9 10:21:39 ubuntu-pvr mythfrontend[1791]: E CoreContext weatherSource.cpp:518 (processExit) script exit status 255

I verified that the package “libdatetime-format-iso8601-perl” is installed.

Perhaps this is a clue?

pvr@ubuntu-pvr:/var/log/mythtv$ nice /usr/share/mythtv/mythweather/scripts/us_nws/ndfd.pl -u ENG -d /home/mythtv/.mythtv/MythWeather/NDFD-6_day +38.55,-089.85
location::+38.55,-089.85
Can't understand returned Content-Encoding (gzip)

Looks like the script does not understand what NDFD is sending it. Has the format changed?

Attachments (0)

Change History (6)

comment:1 Changed 23 months ago by tascholl@…

I have the same issue. It hasn't worked in the last 2 releases.

[root@mythtv mythtv]# /usr/share/mythtv/mythweather/scripts/us_nws/ndfd18.pl -u ENG -d /home/mythtv/.mythtv/MythWeather/NDFD-18_Hour 42.5,-79.28
defined(%hash) is deprecated at /usr/share/perl5/vendor_perl/SOAP/Lite.pm line 466.

(Maybe you should just omit the defined()?)

defined(%hash) is deprecated at /usr/share/perl5/vendor_perl/SOAP/Lite.pm line 2151.

(Maybe you should just omit the defined()?)

18hrlocation::Chautauqua County / Dunkirk Airport, NY
Can't understand returned Content-Encoding (gzip)

comment:2 Changed 23 months ago by beirdo

I'll take a look. As for "it hasn't worked in the last 2 releases", that is questionable. This script has been changed at least once during that timeframe, and this is the first I've heard of the bug.

I'm sure the format has changed, and that's the issue.

comment:3 Changed 22 months ago by Gavin Hurlbut <ghurlbut@…>

  • Resolution set to fixed
  • Status changed from new to closed

In b8a78aeb35167a676a7e25c342a1869e8016d76a/mythtv:

Reworked all of the NOAA/NWS Weather Scripts

Seems weather.gov has moved the urls for nearly all their data services. On
top of that, the SOAP response is gzip encoded by default, and SOAP::Lite is
stupid and can't handle it. Also, we were missing the Units parameter which
is now required.

Fixes #10821

comment:4 Changed 22 months ago by beirdo

  • Milestone changed from unknown to 0.25.2

comment:5 Changed 22 months ago by Gavin Hurlbut <ghurlbut@…>

In 67522d8a9ddfef6512a9d1f0a75f0f1cfef72e0e/mythtv:

Reworked all of the NOAA/NWS Weather Scripts

Seems weather.gov has moved the urls for nearly all their data services. On
top of that, the SOAP response is gzip encoded by default, and SOAP::Lite is
stupid and can't handle it. Also, we were missing the Units parameter which
is now required.

Fixes #10821
(cherry picked from commit b8a78aeb35167a676a7e25c342a1869e8016d76a)

comment:6 Changed 22 months ago by beirdo

On both fixes/0.25 and master

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.