Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 22 months ago

Closed 22 months ago

#10842 closed Bug Report - General (fixed)

SignalHandler does not handle SIGABRT properly.

Reported by: danielk Owned by: beirdo
Priority: minor Milestone: 0.26
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

SIGABRT is used to generate a core dump of a deadlocked program, but our SIGABRT handler will not work when the thread that is deadlocked is the UI thread in which the QSocketNotifier runs. This is related to the issue in #10841. It could be appropriate to return from the SIGABRT handler, the problem is that if we do we may never actually abort.

Attachments (0)

Change History (1)

comment:1 Changed 22 months ago by Daniel Thor Kristjansson <danielk@…>

  • Resolution set to fixed
  • Status changed from new to closed

In e6f993616677b952f6f6687c1526bbf344f7ba48/mythtv:

Fixes #10842. Handle SIGABRT even if UI thread deadlocked.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.