Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#10928 closed Bug Report - Crash (fixed)

Segfault when Launching Live TV

Reported by: skd5aner <skd5aner@…> Owned by: danielk
Priority: minor Milestone: 0.26
Component: MythTV - Video Playback Version: 0.25-fixes
Severity: medium Keywords: LiveTV, segfault
Cc: Ticket locked: no

Description

Recently, I've been experiencing segfaults when launching Live TV. This appears to be sporadic, but is randomly reproducible about 30% of the time Live TV is launched. The segfault usually happens almost immediately.

In 0.24, I do know that a similar issue appeared when the setting to show the guide when Live TV starts was enabled. This appears to have a similar effect to that segfault, but I'm not sure if it's directly related or not so it could be a red herring. To be sure, over a period of the next several days, I will turn that setting off and see if the segfault ever appears.

I almost always use the Live TV jumppoint, but I believe the problem is also reproducible by selecting "Watch TV" from the menu.

Attached is a backtrace and logs set to debug and -v audio,playback,channel

Attachments (3)

gdb.txt (156.4 KB) - added by skd5aner <skd5aner@…> 21 months ago.
gdb backtrace
mythfrontend.20120721210445.14601.log (328.8 KB) - added by skd5aner <skd5aner@…> 21 months ago.
mfe log -v playback,channel,audio
versioninfo.txt (896 bytes) - added by skd5aner <skd5aner@…> 21 months ago.
version info

Download all attachments as: .zip

Change History (7)

Changed 21 months ago by skd5aner <skd5aner@…>

gdb backtrace

Changed 21 months ago by skd5aner <skd5aner@…>

mfe log -v playback,channel,audio

Changed 21 months ago by skd5aner <skd5aner@…>

version info

comment:1 Changed 21 months ago by skd5aner <skd5aner@…>

FYI - several successful Live TV attempts (and recording playbacks) are reflected in the log first, with the final live tv attempt resulting in a segfault.

comment:2 Changed 21 months ago by danielk

  • Milestone changed from unknown to 0.26
  • Owner set to danielk
  • Status changed from new to accepted

Thread 1 is modifying m_recList and thread 61 is using it.

comment:3 Changed 21 months ago by Daniel Thor Kristjansson <danielk@…>

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:4 Changed 21 months ago by Daniel Kristjansson <danielk@…>

In 8e3bc060402cb1be48f7e1d2dd605811ca255096/mythtv:

Fixes #10981. Refs #10928. Convert QMutex to QSemaphore.

Since m_LoadLock is locked in the UI thread and unlocked in
the worker thread it needs to use a QSemaphore instead of
a QMutex. Thanks go to Lawrence Rust for discovering the
issue.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.