Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10969 closed Bug Report - Crash (Fixed)

Arithmatic Expression Core File From mythfrontend

Reported by: Bill Meek <keemllib@…> Owned by: jpoet
Priority: blocker Milestone: 0.26
Component: MythTV - User Interface Library Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I can't reproduce this at will, the steps leading up to it were:

Start FE 
mythfrontend --jumppoint TV Recording Playback --quiet \
    --nodblog -v general --logpath /var/log/mythtv --loglevel debug
Watch an entire show
Using the menu, attempt to mark the show watched

Attachments (3)

gdb20389.txt (75.2 KB) - added by Bill Meek <keemllib@…> 7 years ago.
mythfrontend.20120802025856.20389.log (20.6 KB) - added by Bill Meek <keemllib@…> 7 years ago.
version.txt (765 bytes) - added by Bill Meek <keemllib@…> 7 years ago.
v0.26-alpha-79-gb379de3

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by Bill Meek <keemllib@…>

Attachment: gdb20389.txt added

Changed 7 years ago by Bill Meek <keemllib@…>

Changed 7 years ago by Bill Meek <keemllib@…>

Attachment: version.txt added

v0.26-alpha-79-gb379de3

comment:1 Changed 7 years ago by beirdo

Component: MythTV - GeneralMythTV - User Interface Library
Owner: set to stuartm
Type: Bug Report - GeneralBug Report - Crash

Try changing the 0 to a 1 in that line (mythuibuttonlist.cpp:2048) Not sure it's the proper fix though.

Also, if you could get an actual coredump file, and then in gdb tell it to print m_columns, it could be interesting (may need to do this->m_columns). This looks like a simple div by 0 error.

comment:2 Changed 7 years ago by stuartm

Milestone: unknown0.26
Owner: changed from stuartm to jpoet
Priority: minorblocker
Status: newassigned

I'm not sure what John had in mind there, so re-assigning

comment:3 in reply to:  1 Changed 7 years ago by Bill Meek <keemllib@…>

Replying to beirdo: Unfortunately, I'd already removed the core file (won't make that mistake again.) If I can find a way to reproduce 'on demand', I'll also test the 0->1 change you mentioned.

comment:4 Changed 7 years ago by jpoet

I would need to know which theme was used to have a prayer of reproducing this. That being said, I can see how this would happen, and probably how it should be prevented. I will commit something soon -- although it is not practical to test the fix under every possible situation.

comment:5 Changed 7 years ago by jpoet

Status: assignedaccepted

Fixed (hopefuly) by [ff9073d]

comment:6 Changed 7 years ago by jpoet

Resolution: Fixed
Status: acceptedclosed

comment:7 in reply to:  4 Changed 7 years ago by Bill Meek <keemllib@…>

Replying to jpoet: Steppes 1.5. I've switched to 1.8 and applied ff9073d. Thanks.

Note: See TracTickets for help on using tickets.