Opened 7 years ago

Closed 4 years ago

#10985 closed Bug Report - General (Unverified)

upgraded from 0.25 to 0.25.2 via atrpms, backend no longer has open port to listen

Reported by: johnny@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: 0.25-fixes
Severity: medium Keywords: backend port listening
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

upgraded from 0.25 to 0.25.2 via atrpms, backend no longer has open port

I've even tried to compile my own mythtv from source and I cannot get mythbackend to open a port to listen. It seems to startup ok though.

Here's what the log shows

2012-08-09 11:00:53.183304 C [5958/5958] thread_unknown mythcommandlineparser.cpp:2534 (ConfigureLogging) - mythbackend version:  [v0.25.2] www.mythtv.org
2012-08-09 11:00:53.183385 C [5958/5958] thread_unknown mythcommandlineparser.cpp:2536 (ConfigureLogging) - Qt version: compile: 4.7.2, runtime: 4.7.2
2012-08-09 11:00:53.183391 N [5958/5958] thread_unknown mythcommandlineparser.cpp:2538 (ConfigureLogging) - Enabled verbose msgs:  general
2012-08-09 11:00:53.183673 N [5958/5958] thread_unknown logging.cpp:1176 (logStart) - Setting Log Level to LOG_INFO
2012-08-09 11:00:53.183771 I [5958/5958] thread_unknown logging.cpp:229 (FileLogger) - Added logging to the console
2012-08-09 11:00:53.183839 I [5958/5958] thread_unknown logging.cpp:238 (FileLogger) - Added logging to /var/log/mythtv/mythbackend.20120809110053.5958.log
2012-08-09 11:00:53.183850 I [5958/5958] thread_unknown logging.cpp:425 (DatabaseLogger) - Added database logging to table logging
2012-08-09 11:00:53.183995 N [5958/5958] thread_unknown logging.cpp:1215 (logStart) - Setting up SIGHUP handler
2012-08-09 11:00:53.184133 N [5958/5958] thread_unknown mythdirs.cpp:51 (InitializeMythDirs) - Using runtime prefix = /usr
2012-08-09 11:00:53.184141 N [5958/5958] thread_unknown mythdirs.cpp:57 (InitializeMythDirs) - Read conf dir = /var/lib/mythtv
2012-08-09 11:00:53.184169 N [5958/5958] thread_unknown mythdirs.cpp:64 (InitializeMythDirs) - Using configuration directory = /var/lib/mythtv
2012-08-09 11:00:53.184363 I [5958/5958] CoreContext mythcorecontext.cpp:227 (Init) - Assumed character encoding: en_US.UTF-8
2012-08-09 11:00:53.184935 E [5958/5958] CoreContext mythdb.cpp:866 (LoadDatabaseParamsFromDisk) - Unable to read configuration file mysql.txt
2012-08-09 11:00:53.186265 N [5958/5958] CoreContext mythcontext.cpp:477 (LoadDatabaseSettings) - Empty LocalHostName.
2012-08-09 11:00:53.186287 I [5958/5958] CoreContext mythcontext.cpp:481 (LoadDatabaseSettings) - Using localhost value of mythtv
2012-08-09 11:00:53.186481 I [5958/5958] CoreContext mythcontext.cpp:608 (TestDBconnection) - Testing network connectivity to '192.168.10.5'
2012-08-09 11:00:53.186828 I [5958/5963] SystemSignalManager system-unix.cpp:485 (run) - Starting process signal handler
2012-08-09 11:00:53.186894 I [5958/5964] SystemIOHandlerR system-unix.cpp:90 (run) - Starting IO manager (read)
2012-08-09 11:00:53.188063 I [5958/5965] SystemIOHandlerW system-unix.cpp:90 (run) - Starting IO manager (write)
2012-08-09 11:00:53.188216 I [5958/5962] SystemManager system-unix.cpp:263 (run) - Starting process manager
2012-08-09 11:00:53.358986 N [5958/5958] CoreContext mythcorecontext.cpp:1270 (InitLocale) - Setting QT default locale to en_US
2012-08-09 11:00:53.359005 I [5958/5958] CoreContext mythcorecontext.cpp:1303 (SaveLocaleDefaults) - Current locale en_US
2012-08-09 11:00:53.359067 N [5958/5958] CoreContext mythlocale.cpp:121 (LoadDefaultsFromXML) - Reading locale defaults from /usr/share/mythtv//locales/en_us.xml
2012-08-09 11:00:53.366135 I [5958/5958] CoreContext schemawizard.cpp:117 (Compare) - Current MythTV Schema Version (DBSchemaVer): 1299
2012-08-09 11:00:53.366493 I [5958/5958] CoreContext mythtranslation.cpp:66 (load) - Loading en_us translation for module mythfrontend
2012-08-09 11:00:53.367014 N [5958/5958] CoreContext main_helpers.cpp:556 (run_backend) - MythBackend: Starting up as the master server.
2012-08-09 11:01:23.534886 E [5958/5958] CoreContext cetonstreamhandler.cpp:601 (GetVar) - CetonSH(192.168.200.1-0.0): DoGetVar(192.168.200.1,0,diag,Host_Serial_Number) - unexpected http response: --><html><body><h1>400 Bad Request</h1></body></html><--
2012-08-09 11:01:53.656814 E [5958/5958] CoreContext cetonstreamhandler.cpp:601 (GetVar) - CetonSH(192.168.200.1-0.0): DoGetVar(192.168.200.1,0,cas,CardAuthorization) - unexpected http response: --><html><body><h1>400 Bad Request</h1></body></html><--

Attachments (1)

log.txt (1.1 MB) - added by johnny@… 7 years ago.
log

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by Raymond Wagner

Description: modified (diff)

comment:2 Changed 7 years ago by Raymond Wagner

Status: newinfoneeded_new

There is nothing in your logs to indicate you are having any sort of problem, besides perhaps those last two lines from the InfiniTV recorder. We need more than a single second of data to diagnose anything.

comment:3 Changed 7 years ago by Raymond Wagner

Scratch that, you have one minute of logs there, not one second.

In mythtv-setup, in General, on the first page, what do you have set for those three IP address settings?

comment:4 Changed 7 years ago by johnny@…

I have them both set at 192.168.10.5 which is the IP of eth0. IP Tables is off and so is selinux. I would have put more log files in there but it says that ceton error many times. I don't know if that's a real error or just soft errors.

comment:5 Changed 7 years ago by johnny@…

Here's also what the database says as far as settings is concerned for IP and Port.

[root@mythtv tmp]# grep IP settings.dump PIPLocation 0 mythtv BackendServerIP6 ::1 mythtv BackendServerIP 192.168.10.5 mythtv

[root@mythtv tmp]# grep Port settings.dump UDPNotifyPort 6948 mythtv NetworkControlPort? 6546 mythtv MTDPort 2442 mythtv SipLocalPort? 5060 mythtv AudioLocalPort? 21232 mythtv VideoLocalPort? 21234 mythtv BackendServerPort? 6543 mythtv BackendStatusPort? 6544 mythtv

Version 0, edited 7 years ago by johnny@… (next)

comment:6 Changed 7 years ago by Raymond Wagner

Milestone: 0.25.2unknown
Version: Unspecified0.25-fixes

Within a few seconds of starting the backend, you should be seeing the http and protocol servers coming online with...

2012-07-27 02:15:41.201245 I [5557/102783] CoreContext serverpool.cpp:395 (listen) - Listening on TCP 127.0.0.1:6544
2012-07-27 02:15:41.201320 I [5557/102783] CoreContext serverpool.cpp:395 (listen) - Listening on TCP 192.168.10.5:6544
2012-07-27 02:15:41.201515 I [5557/102783] CoreContext serverpool.cpp:395 (listen) - Listening on TCP [0:0:0:0:0:0:0:1]:6544
2012-07-27 02:15:41.201610 I [5557/102783] CoreContext serverpool.cpp:395 (listen) - Listening on TCP [fe80:1:0:0:0:0:0:1%lo0]:6544
2012-07-27 02:15:42.014819 I [5557/102783] CoreContext serverpool.cpp:395 (listen) - Listening on TCP 127.0.0.1:6543
2012-07-27 02:15:42.014852 I [5557/102783] CoreContext serverpool.cpp:395 (listen) - Listening on TCP 192.168.10.5:6543
2012-07-27 02:15:42.014918 I [5557/102783] CoreContext serverpool.cpp:395 (listen) - Listening on TCP [0:0:0:0:0:0:0:1]:6543
2012-07-27 02:15:42.014956 I [5557/102783] CoreContext serverpool.cpp:395 (listen) - Listening on TCP [fe80:1:0:0:0:0:0:1%lo0]:6543

Or you should see some kind of error indicating the IP address you specified was not available on the system. Or you should see some kind of error indicating why it failed to listen on a certain address. Or you should see some error in the scheduler indicating a fault it detected that would prevent normal operation. At the default general/info log level you are using, there should be some kind of warning indicating something, but I see nothing. Could you increase the log verbosity and try again?

Changed 7 years ago by johnny@…

Attachment: log.txt added

log

comment:7 Changed 7 years ago by johnny@…

Here's a verbose log with --log-level debug and -v all.

comment:8 Changed 7 years ago by Raymond Wagner

Component: MythTV - GeneralMythTV - Recording
Owner: set to danielk
Status: infoneeded_newnew

I'm marking this as a recording issue for now. There is a whole lot that should be happening on startup, that does not appear in the logs, and the errors I see are related to the InfiniTV card. There are a pair of DoGetVar?() calls, one for Host_Serial_Number and one for CardAuthorization?, that take 30 seconds each to time out and fail. My only guess is that this minute long stall is somehow interfering with the rest of the startup sequence.

comment:9 Changed 7 years ago by johnny@…

ok thanks, it's strange because I was on .25 for a while and did not have any issues with the cards load time. I wish I saved my logs to be able to show them as well. I will try to start with a clean database and see if the system loads up properly.

comment:10 Changed 4 years ago by paulh

Resolution: Unverified
Status: newclosed

Closing an old ticket as unverified but almost certainly a user config error off some sort.

Note: See TracTickets for help on using tickets.