Opened 7 years ago

Closed 7 years ago

#11019 closed Patch - Bug Fix (Duplicate)

Browse mode in LiveTV - video/audio stops < 1s - Windows Frontend

Reported by: Shinck@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25-fixes
Severity: medium Keywords: CannelIcon
Cc: Ticket locked: no

Description

At my windows-frontend of mythtv in liveTV I wondered why in browse mode video/audio stops for an annoying time (but < 1s) if i display another channel. After some investigation i discovered that this was caused by the channel icon, that was requested and downloaded from the backends StorageGroup? which stopped reading from the ringbuffer for that time. I saw ticket #10659 and commit [cda7871] and decided to revert portions of the old code, that build an IconCache? on the local frontend, but based on the new StorageGroup? and the icons stored in the database without the (absolute)path, so that Icon-display wouldn't be broken an any remote-frontend independet of the local frontend Configuration-path.

So now I provide the patch. Perhaps it could be helpful for some other people.

Attachments (4)

0001-Cache-Channelicons-in-local-folder.patch (9.5 KB) - added by Shinck@… 7 years ago.
At remote-frontends cache ChannelIcons? in an local folder
version_windows.txt (413 bytes) - added by Shinck@… 7 years ago.
Version information
0002-Cache-Channelicons-in-local-folder-026.patch (9.5 KB) - added by Shinck@… 7 years ago.
Patch for master / 0.26-rc
version026-windows.txt (417 bytes) - added by Shinck@… 7 years ago.
Version information 0.26

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by Shinck@…

At remote-frontends cache ChannelIcons? in an local folder

Changed 7 years ago by Shinck@…

Attachment: version_windows.txt added

Version information

comment:1 Changed 7 years ago by Shinck@…

Annotation: The physical connection between WindowsXp?-frontend and Mythbuntu10.04-backend is an Gigabit-Ethernet Link so this couldn't be an performance issue.

comment:2 Changed 7 years ago by Shinck@…

Recently I switched from fixes/0.25 to master. The patch also works fine. So I will attach it here.

Changed 7 years ago by Shinck@…

Patch for master / 0.26-rc

Changed 7 years ago by Shinck@…

Attachment: version026-windows.txt added

Version information 0.26

comment:3 Changed 7 years ago by stuartm

The breakage is somewhere in the image cache, we shouldn't need a secondary cache just for icons so the patch, while appreciated, isn't going to be applied. Closing this as a duplicate of #10788 where we'll try to get at the root cause of the problem.

comment:4 Changed 7 years ago by stuartm

Resolution: Duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.